cancel
Showing results for 
Search instead for 
Did you mean: 

Delta S Wireless not working in 2.4

Silently
Level 8

Hello,

I bought td Delta S Wireless in December, and I've already had to send it back in February for another problem (it wouldn't start up at all). I got a fresh new headset exchange.

Since this morning, the headset no longer works in 2.4, it only works in BT.

When I switch it on in 2.4, there's a little "beep", but that's all. It's recognized, but that's all. No sound. No mic. The settings are not accessible. The blue LED flashes.
In BT there's a little "beep" and then "connected". The headset works. The blue LED is steady.

When I plug it in, it says "PC Mode" but that's all. The updates (I formatted the whole PC today, for this problem) are in error, it asks me to connect the cable and the dongle, both are connected.

I think the problem is with the dongle. I haven't seen any way to factory reset either the headset or the dongle, this feature isn't provided (for a 200€ headset).

Item Version
---- -------
Armoury Crate UWP App 5.6.8.0
ROG Live Service 2.1.4.0
Aura Service (Lighting Service) 3.07.17
Armoury Crate service 5.6.8
Aura Wallpaper Service Non installée
Aura SDK 3.04.32
ASUS Aac_NBDT HAL 2.5.29.0
ASUS Mouse Extern HAL 1.2.0.6
ASUS Mouse HAL 1.2.0.58
AacAudioHal 1.3.50.0

18,384 Views
125 REPLIES 125

Nate152
Moderator

Thank you,

With the usb-c to usb-a dongle adapter connected, set the switch on your headset to 2.4GHz wireless mode.

Next, try using the Armoury Crate uninstall tool and reinstalling.

In the link below select your operating system, click "Show all" in blue, the uninstall tool is the third download.

Armoury Crate - Support (asus.com)

Once uninstalled, install Armoury Crate version 3.2.7.2 (first download) then head to the update center and check for updates.

If your headset is not being detected in 2.4GHz wireless mode, it's possible it needs charged.

 

Same error

When this error is on, if I turn off the headset and put it back on 2.4 the message disappear and the circle turns.. unfortunately with no results, if connected with Bluetooth all good.. any other options for 2.4 ?

Thank you

Have you tried reinstalling Armoury Crate?

Make sure you have the wireless dongle connected directly to a pc usb port.

What happens if you let it on the spinning circle, does the page eventually load? 

 

becmarius
Level 8

Is there any tool to pair them two together dongle and headset ?

Send me mail

mehmetk01001@gmail.com

 

Hi,i did sent you an email, thank you

LowriderGTS
Level 8

So a week after i have uninstall Asus Rog Wireless from "device manager" and restarted Windows, headset works fine on 2.4. No issues. Windows install headset automatically after restart.

No programs, downloads or other shady stuff. For me issue started after i updated headset in AC. AC is now on 5.6.8.0, and headset is on 4.0.1.3 version. Works fine. 

Those who dare, i salute you.

I was trying that but is not detecting the headset

Dotsi
Level 7

Hey also have this issue, I've tried everything in this thread. Uninstalling armory crate, uninstalling drivers, even reinstalling base audio drivers. None of it works, the dongle is simply not connected to the headphones.

No_Mercy
Level 7

Я тоже столкнулся с такой же проблемой, не могли бы вы помочь мне с ней справиться, пожалуйста.