cancel
Showing results for 
Search instead for 
Did you mean: 

Delta S Wireless not working in 2.4

Silently
Level 8

Hello,

I bought td Delta S Wireless in December, and I've already had to send it back in February for another problem (it wouldn't start up at all). I got a fresh new headset exchange.

Since this morning, the headset no longer works in 2.4, it only works in BT.

When I switch it on in 2.4, there's a little "beep", but that's all. It's recognized, but that's all. No sound. No mic. The settings are not accessible. The blue LED flashes.
In BT there's a little "beep" and then "connected". The headset works. The blue LED is steady.

When I plug it in, it says "PC Mode" but that's all. The updates (I formatted the whole PC today, for this problem) are in error, it asks me to connect the cable and the dongle, both are connected.

I think the problem is with the dongle. I haven't seen any way to factory reset either the headset or the dongle, this feature isn't provided (for a 200€ headset).

Item Version
---- -------
Armoury Crate UWP App 5.6.8.0
ROG Live Service 2.1.4.0
Aura Service (Lighting Service) 3.07.17
Armoury Crate service 5.6.8
Aura Wallpaper Service Non installée
Aura SDK 3.04.32
ASUS Aac_NBDT HAL 2.5.29.0
ASUS Mouse Extern HAL 1.2.0.6
ASUS Mouse HAL 1.2.0.58
AacAudioHal 1.3.50.0

599 Views
125 REPLIES 125

Ziggy86
Level 7

i have a similar problem, my headset simply doesnt turn on... the led is red when charging but as soon as i dissconnect there are no lights at all in all 3 positions... please help this is my 2nd pair of the headset 😞

Jiaszzz_ROG
Customer Service Agent

Hello, @Ziggy86 

Could you please clarify if the issue you're facing involves the headset not powering on at all, with only the charging indicator lighting up? 
Did it occur after a firmware update or when connecting a specific device?
Is Armoury Crate or the system recognizing the headset when you connect it to a PC or laptop?
Meanwhile, as I mentioned earlier in the thread, this discussion is intended for situations where only the ROG Delta S Wireless 2.4G connection is experiencing problems. 
We recommend starting a new discussion thread to avoid any confusion with the main topic of this thread.

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

HanzoX7
Level 8

I'm glad Asus decided to fix their issue a few months after the fact. My Delta S Wireless unpaired itself in May shortly after Armoury Crate decided to update either the firmware or something else. I chatted and emailed support, no luck. The agent I chatted with was to send the headset back for a possible replacement. Using the pairing tool fixed the issue in less than 5 minutes, although, for any future users, the instructions on the tool say to press the function button until it beeps or something. I held the button for about a minute or so and the headset never beeped or said anything, the "pair" button was lit up as soon as I opened up the app.

Now, please fix the audio in Armoury Crate. No matter what setting I change, the headset doesn't respond. I'm listening and changing the EQ, toggling Virtual Surround on and off, etc... no changes to the sound at all.

Jiaszzz_ROG
Customer Service Agent

Hello, @HanzoX7 

Based on the description you provided, we recommend using the Armoury Crate uninstall tool to remove Armoury Crate, then reinstalling it and going to the Armoury Crate update center to complete all available updates before checking again.
Please refer to the [ASUS Armoury Crate] Armoury Crate FAQ for the guide to uninstallation if needed.

If you continue to experience issues with your sound settings, we suggest providing screenshots of your Armoury Crate update center, farmware version of the Delta S Wireless, and relevant context via starting a new discussion thread to avoid confusion with the current topic.

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

Rand0nbran
Level 7

Hi, im facing the same issue, blue light flashing when switched to 2.4G mode, tried paring with another PC, same thing happened.
Able to connect via bluetooth and did a filware update using the amoury app but same problem pesist. Tried to attempt headset pairing tool but the pair button remains greyed out. please assist. Thank you.

Jiaszzz_ROG
Customer Service Agent

Hello, @Rand0nbran 

Thank you for reaching out to us.
Based on your description, since you have already attempted cross-testing different connection devices and verified for any relevant updates, yet the issue persists, we recommend contacting the original place of purchase or ASUS customer support in your region.
Please provide the serial number of the headset and detailed context to facilitate further arrangements for repair and diagnosis.

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂