cancel
Showing results for 
Search instead for 
Did you mean: 

Delta S Wireless not working in 2.4 help me

mertcesur
Level 7

ı formatted many times and tried resetting 2.4ghz many times 

bluetooth connects but the headset does not see 2.4ghz what should ı do please help

344 Views
16 REPLIES 16

Aureliannn_ROG
Customer Service Agent

Hi @mertcesur ,

we're really sorry you're experiencing issues. Here's our solution: please refer to the following FAQ link for troubleshooting steps:
[Peripherals & Accessories][ROG Delta S Wireless] How to do if The 2.4G doesn't work, or the headset...

If you need further assistance or have any other questions, please don't hesitate to let us know. 

Thank you.

Providing detailed device specifications (MB/CPU/GPU/PSU, etc.) and the respective driver versions, OS version, and BIOS version will help us analyze the issue more effectively.

I tried many times but it doesn t work what should I do 😞

Nate152
Moderator

yes sir I tried everything it doesn t work many times what should I do please help me

Nate152
Moderator

Try carefully going over the steps again in the link Aureliannn_ ROG posted.

Be sure both the cable and the wireless dongle are connected to pc usb ports.

Tell us at what point in the steps the problem occurs. Try to be detailed as possible.

 

 

 

 

 

one day I left my headphones charging while going to work and when I came back the light was not on 

I then tried setting it to 0 many times but it didn t work 

2.4ghz light kept blinking connection failed 

what should I do tried everything many times 

please help me 

Nate152
Moderator

Try this.

1) Disconnect the wireless receiver.

2) Reboot your pc.

3) Connect the wireless receiver.

4) Try pairing it again.

5) If this doesn't help, check for updates in Armoury Crate.

 

ı cant update the update doesn t appear I did eerything else over and again 

please help 😞

update version 0.0.0.16 

I cant check the update because I m connected via bluetooth