cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Strix GO 2.4 Headphones

Chrisg333
Level 8

Hi All

I've just bought a pair of the Strix GO 2.4 headphones (second hand). It seems that my set is suffering from the common issue of no wireless connection, I have tried to update the firmware by connecting both the wireless dongle and the usb cable to the headphones but it constantly errors asking for the dongle and cable to be replugged in and try again, I've tried this on 4 different laptop and it's the same outcome every time, has anyone got any idea what I can try next or is it a lost cause, the headphones work fine using the 3.5mm audio lead.

 

Thanks for any help.

341 Views
21 REPLIES 21

I have the same problem, if you find out what needs to be done to fix it, tell me.

Aureliannn_ROG
Customer Service Agent

Hi @Vlad12 ,

based on your issue, may I ask whether the issue is related to the audio not working when using a 2.4GHz wireless connection, but it functions correctly when using a wired connection? Have you cross test with other device?

Could you confirm if your firmware is updated to version 3763?

Additionally, could you provide a screenshot of any error messages you encounter?

Please specify when the problem occurs and whether you've made any recent changes to your settings.

To assist you further, we kindly request that you record and provide relevant logs for our investigation. You can find instructions for log operations in Q5: "What is App Diagnostics?" on our FAQ page here: https://www.asus.com/support/FAQ/1043747/#a14

After recording the log, please upload it to the cloud, grant access, and send me the link.

Thank you for your cooperation.

Providing detailed device specifications (MB/CPU/GPU/PSU, etc.) and the respective driver versions, OS version, and BIOS version will help us analyze the issue more effectively.