cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Rog Theta 7.1 Mic Problem

Zaris24
Level 7

So recently my Microphone Either stops working i have to Pull it out an replug it  and then it might work for a bit of time again before just dieing again  its either that or it turns red an Wont be unmuted 

I can easly try to unmute it 5 times with out any luck

Im thinking it might be a driver problem when i wanted to look for driver or firmware i got kinda stuck as all refer to armorycraft so not much help there

Really hopeing that 

some one can tell me what to do ide hate to have to spend alot of cash on a new one  if its only the mic thats the problem and im guesing trying to fit in another mic wont work right ?

464 Views
5 REPLIES 5

Aureliannn_ROG
Customer Service Agent

Hi @Zaris24 ,

based on your issue, may I ask have you make sure that ROG Theta 7.1 firmware is at the latest version?

Does the issue occur with any specific software? 

Did the problem arise after updating or modifying any settings? 

Have you set the ROG Theta 7.1 as the audio output device? 

Additionally, could you please share the Armoury Crate version, and provide a screenshot of the Armoury Crate Update Center? 

You can refer to the following link.

[Windows 11/10] Sound settings and Volume Mixer | Official Support | ASUS Global

Thank you.

To the Firmware No as in i dont know where to do it  (Okay so i set it to update all and it just did again made a reinstall of win11 recently )

To the software no its the same even if i use skype discord or other voice things

to the update No idea tbh most updates i dont see as most of time i turn on the pc an it updates it self before im back at the pc (No idea if armory crate updated it self before i made the reinstall)

Output device is all set to Rog Theta 7.1 skype discord 

Armory version 5.7.6.0

 

 I just Updated all i can in there when i click search for update it dosent find any thing 

So im gues i have test my mic out a few days to see if it works or not now 

found it a bit weird with the firmware tho caus i clicked update then restarted 

an then it poped up again under updates then i clicked search again for updates an then it was gone an when i found the firmware it said it had the version i installed before V.0043 date 2022/09/13

 

Hey,

I have the same issue with my Theta 7.1, the red light is always on, I just installed the latest version of Armoury crate 5.7.9.0, ROG theta is set as the audio input/output device, I didnt modify anything. few days ago the mic just stops working and i had to restart the computer. lately was working fine but now is isnt. I did some research, to many people who bought it have mic issues.

Thanks for help

Zaris24
Level 7

So i have now tested the headset its sadly still the same mic works under 50% of the time then pull out  put back in works for like 10min then same prob again

all is updated

Onryō
Level 7

Hey,

support team sent me armoury crate uninstall and install links, and it worked and hope nothing happens again.

We invite you to uninstall the Armory Crate utility from the link below:

https://dlcdnets.asus.com/pub/ASUS/mb/14Utilities/Armoury_Crate_Uninstall_Tool.zip?model=ROG%20Theta...

Subsequently, we invite you to install it from the link below:

https://dlcdnets.asus.com/pub/ASUS/mb/14Utilities/ArmouryCrateInstallTool.zip?model=ROG%20Theta%207....

Here are the links if it somebody needs it.

thanks