cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Strix Arion Enclosure (NVME) Not showing up on Desktop - Rampage IV Extreme

dbit
Level 7
I purchased a new Micron NVME drive and put it into a ROG Strix Arion enclosure (to match my 2022 Zephyrus).

Unfortunately when I plug the drive into my rampage iv extreme machine, absolutely nothing happens. The drive shows up on all of my other desktops and laptops. I updated the BIOS, did the CAP conversion, updated to the most recent BIOS, tried to installed the latest USB 3 drivers available on the asus site (although nothing visible happened when I launched the setup other uses said that behavior is normal), went into the BIOS and enabled all the USB 3.0 options avalable there, still no dice!

I don't see any USB mass storage driver load up. I don't even see the 'eject' option to eject the drive. The lights come on but it's like nothing happens!

Any thoughts on what might be going on here?
1,254 Views
1 REPLY 1

xeromist
Moderator
I would check device manager to see if anything is flagged with a warning. Also, you could check the Disk Management panel in Windows but if the device driver isn't loading you won't see it there.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…