cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Balteus QI not working in armory crate

joewakim
Level 8

Hello,

Please help, my ROG Balteus QI mousepad is not opening in the Armory Crate Application, when i click on the Balteus Qi under "devices" the application just shows a loading message that keeps running forever then crashes, showing a message that the application will try to reload the device, and then keeps on repeating the same loop. However, I am able to connect the Balteus Qi to aura sync under the aura sync section, but i cannot access the settings under the Devices Section. I tried uninstalling and re-downloading the drivers on PC, I completely Uninstalled Armory Crate and re-downloaded it, updated my windows, and updated everything in the MyAsus application, But the issue is still happening. Any Suggestions?

759 Views
18 REPLIES 18

LordSabathan
Level 9

I have the same issue -Balteus (normal version).Page not loading , but i see it on aura device page and can sync it with other devices.

Wolfszen
Level 8

I just uninstalled ac and not gonna reinstall again for an uncertain time. I spent so many hours to fix a small and absurd problem but no fix. It is enough for me to give up. Good luck rest of all. Gonna follow the topic just in case.

I reinstalled, too and it worked for 5min. hehe This software is trash!!!!

endur4nc3
Level 7

i have the same issue, just bought it today and it keeps loading in the armoury crate. so asus please provide software update ASAP! h-2005 error code.

Don't worry about it, Guys! Just an Asus software malfunction.

I have the same issue

Let us wait patiently

Problem today solved success. Please update Crate!

Sibe
Level 7

same issue for me also!

Aureliannn_ROG
Customer Service Agent

Hi all,

based on your query, the issue has been investigated by the relevant department, and a new version has been released.

Please update to the latest version, which is ROG Balteus/ROG Balteus QI HTML v4.01.04 and Framework MSP Plugin v1.2.3, released on 11/6.

Kindly perform the update and check if the problem still persists.

Thank you for your cooperation.

Providing detailed device specifications (MB/CPU/GPU/PSU, etc.) and the respective driver versions, OS version, and BIOS version will help us analyze the issue more effectively.

nbelancic_
Level 9

Problem is fixed thank you!!!!