cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Azoth HAL firmware error 4151

jintonic0106
Level 7

I purchased ROG Azoth to match up with the G14 Zephyrus laptop and for some reason my HAL would not update. 

I tried everything that were mentioned on the forums such as;

- Re-installing the Armory Crate after uninstalling and using the CCleaner to delete all the registries. 

- Taking the keyboard USB off while installation of the Armory Crate and plugging it on wired along with 2.4hz usb connected as well.

However, now the error doesn't appear but rather just keeps showing the update and keeps saying I need to update the firmware if I try clicking onto the ROG AZOTH in the tab. 

This should not be this difficult they are both ROG/ASUS and seems like this is a common issue within the ROG users and it is ridiculous how there are issues with the software and restricting the users from utilising the full potential of this keyboard such as changing the led display or monitoring the CPU and GPU temp. 

1,404 Views
8 REPLIES 8

Aureliannn_ROG
Customer Service Agent

Hi @jintonic0106 ,

based on your issue, have you updated both your keyboard firmware and Armoury Crate update center to the latest versions? 
Please kindly provide the Armoury Crate version and a screenshot of the Armoury Crate Update Center and the error messege.

Could you also help record and provide the relevant logs for us to investigate further?
For log operation steps, please refer to Q5: What is App Diagnostics? (New Feature)
https://www.asus.com/support/FAQ/1043747/#a14
After recording the log, please upload it to the cloud, approve access, and PM me the link.
Additionally, kindly provide the product serial number too, thank you.

Providing detailed device specifications (MB/CPU/GPU/PSU, etc.) and the respective driver versions, OS version, and BIOS version will help us analyze the issue more effectively.

Hi @erpipe ,

may I ask when did the issue occur?

Have you make sure that Armoury Crate version and keyboard firmware is at the latest version?

Please kindly provide the Armoury Crate version and a screenshot of the Armoury Crate Update Center and the error messege.
Could you also help record and provide the relevant logs for us to investigate further?
For log operation steps, please refer to Q5: What is App Diagnostics? (New Feature)
https://www.asus.com/support/FAQ/1043747/#a14
After recording the log, please upload it to the cloud, approve access, and PM me the link.
Additionally, kindly provide the product serial number too, thank you.

Providing detailed device specifications (MB/CPU/GPU/PSU, etc.) and the respective driver versions, OS version, and BIOS version will help us analyze the issue more effectively.

erpipe
Level 7

I have the same problem. I have the Asus azoth and I cant uptdate the driver "HAL Rog azoth", Error code, 4151

thechrisbondoc
Level 7

Same error, 4151

Hi @thechrisbondoc ,

based on your issue,

may I ask when did the issue occur?

Have you make sure that Armoury Crate version and keyboard firmware is at the latest version?

Please kindly provide the Armoury Crate version and a screenshot of the Armoury Crate Update Center and the error messege.
Could you also help record and provide the relevant logs for us to investigate further?
For log operation steps, please refer to Q5: What is App Diagnostics? (New Feature)
https://www.asus.com/support/FAQ/1043747/#a14
After recording the log, please upload it to the cloud, approve access, and PM me the link.
Additionally, kindly provide the product serial number too, thank you.

Providing detailed device specifications (MB/CPU/GPU/PSU, etc.) and the respective driver versions, OS version, and BIOS version will help us analyze the issue more effectively.

I was able to resolve it by uninstalling armoury crate and reinstalling

Yeah, I saw few response saying uninstalling and reinstalling potentially fixes the issues, unfortunately it didn't do the trick for me 😞

BigArabDaddy2
Level 7

I'm having the same issue, the armory crate app is updated, and uninstalled and reinstalled it as it's been suggested by some replies above. Any suggestions?