cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Azoth detecting wrong (multiple) inputs

virtuun
Level 7

 

Hi, I updated my ROG Azoth (Nordic version) through Armoury Crate today, and now it's going completely bonkers.

Looking at the versions listed in AC, the keyboard has version 4.00.07, the dongle has version 5.00.07.

For some keys, when I press the key down, one of the keys next to it also registers as pressed. So for example if I press ',' (comma), then '.' (period) is also written. If I press 'O' then 'P' is also written. And it goes both ways, so regardless of if I press 'O' or 'P', the keyboard writes 'OP'.

A different older keyboard works perfectly sane. I tested plugging the Azoth keyboard into a different pc with no AC, and the problem was present there as well.

The affected key-pairs that I've found are

F9-F10, 9-0, O-P, L-Ø, comma-period, Alt Gr-Fn

 

579 Views
7 REPLIES 7

Nate152
Moderator

Hello vertuun

Try resetting your ROG Azoth by pressing and holding the Fn + Esc keys until the lights flash green.

Does this get the keys working properly?

 

 

 

 

Held it till it said "reset successful" but didn't help unfortunately.

Aureliannn_ROG
Customer Service Agent

Hi @virtuun ,

based on your issue, may I ask whether the issue occur after you update the Armoury Crate or the keyboard firmware?

Have you try to use the Uninstall tool to reinstall the Armoruy Crate?

Kindly provide the screenshot of the Armoury Crate update center and the current Armoury Crate version.

Could you also help record and provide the relevant logs for us to investigate further?
For log operation steps, please refer to Q5: What is App Diagnostics? (New Feature)
https://www.asus.com/support/FAQ/1043747/#a14
After recording the log, please upload it to the cloud, approve access, and PM me the link.
Additionally, kindly provide the product serial number too, thank you.

Sent you the pm now.

The problem occurred after I updated the keyboard firmware in AC. I haven't tried reinstalling AC since the problem was present when I connected the keyboard to other computers (without AC) as well.

Here's a screenshot from AC:

ac screen.png

Aureliannn_ROG
Customer Service Agent

Hi @virtuun ,

thank you for the information you've provided. 

We've passed your details on to our relevant backend team for analysis. 

Please be patient and wait for any updates or messages from us. 

Thank you.

Aureliannn_ROG
Customer Service Agent

Hi @virtuun ,

the backend team needs your assistance in performing the following steps:

1. Hold "Fn + esc" to execute the HW reset, keep holding until the entire keyboard flashes green, then release – Confirm if the issue can be resolved.
2. Please remove and reinstall the problematic keys (O, P) – Confirm if the issue can be resolved.
3. If the issue persists after the above two steps, please help us by recording a video (including pressing and send) for our confirmation.

Thank you.

Resetting didn't help, but removing the switches and reinstalling them did the trick. Thanks for your hjelp!

Edit: The problem came back after some hours. I tried removing the switches again, but it didn't help this time. I'll make a recording as soon as I'm able.

Edit2: Sent the video in pm now.