Showing results for 
Search instead for 
Did you mean: 

Balteus QI no longer working.

Level 7
My Balteus QI is no longer showing up in Armoury Crate, and the LED's are dark. It does not respond to pressing the button on the hub either. Not even when using the wireless charger, which otherwise works fine..

I have one unknown device in my device manager which has to be it (unknown usb device (device descriptor request failed)). I have tried to update the driver, but I don't have one, and Windows update can't find one. I have tried googling for a driver, but all hits are directing me to Armoury Crate or Armoury II. I have tried searching for a driver in their respective folders, but to no avail. I don't understand why Asus don't have the device drivers available in the support section...

Anyone have tips or drivers for the pad?

Level 7
Are you getting the "Issue with this USB device" when you unplug/plug in the pad, then you are going to need to RMA the pad.
Samething happened to mine and there is a bunch of threads around the internet about it.

Any idea what's going on with this ... 'thing'?
Dead before born!!!! Mine lasted just one plug in -maiden-, then RIP...!
I think I'm having enough with those ROG Strix expensive craps!!!