cancel
Showing results for 
Search instead for 
Did you mean: 

[FIRMWARE] Intel ME (H610/B660/H670/Z690/B760/H770/Z790)

MoKiChU
Level 40

Hi everyone,

- Intel ME Consumer Firmware :

Firmware : 16.1.30.2361 [11/12/2023]
PMC Firmware : 160.2.00.1043 [06/09/2023]
PCHC Firmware : 16.1.0.1014 [06/07/2022]
PHY N Firmware : 13.62.211.7255 [21/06/2023]
PHY S Firmware : 13.0.1.7085 [30/01/2023]
Download : Link

Check/Update Process :

Check current version : Right click on "Check.cmd" > Run as administrator

Install/Update : Right click on "Install.cmd" > Run as administrator > Automatic restart when install is done


OS requirements : Windows 10 64 bit or more recent.
Hardware requirements : Motherboards with Intel H610/B660/H670/Z690/B760/H770/Z790 chipset.

206,004 Views
229 REPLIES 229

MoKiChU
Level 40

Hi everyone,

- Intel ME Consumer Firmware :

Firmware : 16.1.30.2361 [11/12/2023]
PMC Firmware : 160.2.00.1043 [06/09/2023]
PCHC Firmware : 16.1.0.1014 [06/07/2022]
PHY N Firmware : 13.62.211.7255 [21/06/2023]
PHY S Firmware : 13.0.1.7085 [30/01/2023]


Thread updated.

JohnAb
Level 17

Thanks MoKiChU - just a comment in case this helps anybody else re: ME Firmware 16.1.30.2361...

For a while now, (at least a few days) my aRGB light strips had stopped responding in Armoury Crate. iCue has also not been able to complete software updates - I was sure this was related to the fact that my light strips could no longer be detected and also in iCue, the normal motherboard options had vanished. HWInfo was still detecting motherboard sensors normally though. This might have happened since I updated the BIOS the other day, that's really the only recent change that I've made. 

I was going to do a complete Windows reinstall to try and fix things, but I just installed the latest ME Firmware available here and as soon as I rebooted, the light strips were working properly and iCUE/Armoury Crate are also working normally again. I didn't expect that, but it seems like more than a coincidence 😄

Z690 Hero, 12900K, BIOS 3501, MEI 2406.5.5.0, ME Firmware 16.1.30.2361, 7000X Case, RM1000x PSU, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

tipes
Level 10

Just curious anybody tested this on a 790 board - any feedback appreciated,before I take the leap.

Runs fine on my Z790 Apex.

Thanks for the confirmation Simk1n. Will give it a go then.

Z790-E BIOS 2002 13900KS

ME 16.1.30.2361 runs fine here. Did not noticed any difference between 2307, 2330 and 2361

derailius
Level 7

...

dealpapa
Level 8

Intel Management Engine (ME) Firmware Version 16.1.32.2418 

arlicht
Level 9

@MoKiChU  Is there a link for previous 16.1.30.2307 ME firmware?