Showing results for 
Search instead for 
Did you mean: 

G skill royal trident z ram not detected in aura creator

Level 11
Like the titel says: G skill royal trident z ram not detected in aura creator.
Thats my main problem with armoury crate/aura creator and i could not find the sticky post about issues for this tool.

So do anyone know when they will fix this problem ?
And do anyone else with the same g skill ram have the same problem with ther ram not showing up in aura creator for RGB config.
I need to controlle th elight with g skill own software but armoury crate should be able to detect my ram. But it dosent work for some reason.
I was told it was gona be fixed in a update late may. So i still have hope 😄

Level 7
I built a pc back in June and the ram worked right after I installed the G Skills Trident Z Lighting Control. Sometimes stuff just doesn't work with Armoury Crate. Hope You figured it out.

Level 9
Today ASUS Central HAL was updated and G.Skill memos are syncing again! Cheers!!!

OS: Microsoft Windows 10 Home 64-bit Ver.2009 (OS build 19044.1889)
BIOS Version: 1720
BIOS Release Date: 08/12/2022
CPU: 12th Gen Intel(R) Core(TM) i9-12900KS
Memory: 64 GB @
- 16 GB DDR4-3200, G Skill Intl F4-3200C14-16GTZR
- 16 GB DDR4-3200, G Skill Intl F4-3200C14-16GTZR
- 16 GB DDR4-3200, G Skill Intl F4-3200C14-16GTZR
- 16 GB DDR4-3200, G Skill Intl F4-3200C14-16GTZR
Graphics: NVIDIA GeForce RTX 2080 Ti, 11264 MB
VBIOS Version: 90.02.0B.00.74
Drive: SSD, Samsung SSD 970 PRO 1TB, 953.87 GB
Drive: SSD, Samsung SSD 960 PRO 1TB, 953.87 GB
Network: Intel(R) Ethernet Controller (3) I225-V
Network: Intel(R) Wi-Fi 6 AX201 160MHz
Power Plan: GUID: 381b4222-f694-41f0-9685-ff5bb260df2e (Balanced)

Ok, So I have a 64 gb ram kit 3200 CL14 which I pulled from my previous build. I went from amd to intel, RGB worked fine. I did have asus board and all the same software. But funny enough I don"t like armoury crate. I never installed it first on this build. I installed aura sync by it self first. Only my ram was being detected.
My ram worked and did exactly what I want it to do which is comet. but nothing else worked, not the motherboard or my case lighting which is phantek from my previous build which I know it works. So I call asus, they tell me its a bad board send it in to fix. But I don't, I'm too busy for that. I leave it for a month or so, until it starts bothering me again. I search forums to see if anyone had or solved this problem of mine. I caved and installed armoury crate, (its growing on me!) Now after some updates I have armoury crate detecting everything. My lighting strips, motherboard and ram. But aura creator only detects mother board and lighting strips, not ram. I had to download gskill software for amoury crate to detect ram, plus had to power off pc for 15 sec. before reboot. Note my gskill software cant control my ram at all, ever. My ram does not light up anymore at this time. I have uninstalled everything properly and reinstalled them in different orders. I'm stuck. When I looked up aura creator it doesn't say anything about gskill compatible. did they have a fight, and now not accommodating them anymore? Note: in my previous build I had a uninstall able program called "Patriot" I always wondered if that was wrong because I have gskill ram not Patriot ram. and now I have something called aura lighting effect.

Hope this gives someone an idea on how to solve this problem.