Showing results for 
Search instead for 
Did you mean: 

Armoury Create Update Problem

Level 8


How do you resolve this? I am trying to update but no success...1.PNG2.PNG3.PNG


Level 7

i have the Same Problem ...

Level 7

Same problem 😭

Level 7

Did you try the uninstall tool from AC site and then choose the Version  AC install that worked for me I was having the same issue for these updates and got the same error message and the only fix was to use the uninstall tool restart pc and then use latest AC install and once it installs let it update what it shows in updates that is ready to install and restart again. All updated fine with a couple restarts after they install.

Level 11


It can't be that we users should uninstall a working program just so that a defective update can be applied.

The current update to and everything else that comes with it is definitely defective or has errors, which means that the update itself does not work.
Asus has to provide a remedy here, not the user, because the update has apparently not been tested by Asus to see whether it actually runs on a functioning system.

Of course, a new installation of Armory Crate has the advantage that current updates are installed at the same time, but the point of an update is not to have to completely reinstall a program.
Imagine something like this would happen with Windows and you would have to reinstall it because an update didn't work.

Here the updater seems to have a problem with the connection to the server (see identical error message that many users have here), where the update is located and Asus has to fix that, not the user.

Intel Core i7 13700K / AiO Fractal Design Lumen S36 v2 RGB / Asus Rog Strix Z790-F Gaming WIFI / Corsair Dominator Platinum DDR5-5600 64GB (4x 16GB) / Asus TUF RTX 4070 ti OC / 4x Samsung 980 pro 1TB / Seasonic Prime GX 850 W Gold / Fractal Design Meshify 2 Lite RGB Black TG Light Tint / Monitor AOC Q27G2S/EU (WQHD)

Level 11

To all:
I had the same problem a few days ago... 

Even though I have a very clean and solid internet connection, sometimes I can't connect to ASUS' websites.  Suspecting that the updater couldn't connect to ASUS' download site, I shutdown Armoury Crate, rebooted my PC, then tried the update again... a few times.  It finally connected to ASUS' download site and installed the update.

ASUS needs to do a better job of making sure its links work, especially for updates like that.  Frustrating their users like that will loose them customers.

Have a Good One! 😎

Level 7

I have the same problem,reply when you get a solution please😞

Level 7


Level 7
  • hey guys I've been going through these same issues for a few Frustrating days  
    OS: Windows 10 Pro 64-bit (10.0, Build 19045 / 22H2
    System DIY
    System Model: ROG STRIX HX570-E GAMING WIFI II / BIOS: 5003 (type: UEFI)
    CPU: AMD Ryzen 9 5950X 16-Core Processor
    Memory: Corsair DDR4-4000 32Gb RAM
    GPU: AMD Radeon RX 7800 XT
    what I had to do was go into the Bios & turn off the ( Armoury crate download )
  • took me a few day of Frustration to figure out that the windows store was trying to update the program 
  • I had to login to WINDOWS Store after that it was still a few days of Frustration BUT after that it started working for me 
    PS: for years I was on the win 10 Pro 64 / ver. 2004 I went into the win Reg & made it to where it wouldn't update after ver. 2004 I prefer to be in control of my system NOT Windows But!! these days Microsoft thinks we don't Know what we are doing & has made it to where we can't control OUR PC systems any more 😪