Showing results for 
Search instead for 
Did you mean: 

Windows 8.1 - DirectX problems after update

Level 7

Everything was normal with my one-year-old AsusG75VW There were no problems at all, but then...
About one week ago, Windows asked me to install just regular automatic Windows update and installed it. After this I have been had these weird problems like:
- Nearly every game crashes or I can't even run it
- Can't install or run new .exe files
- Software crashing
- nVidia GPU driver lost connection

Example when playing BF3 there comes this "DirectX... badly formed commands..." and playing Bioshock Infinite, Far Cry 3, AC4, Skyrim.. they just crash and I can't close the programs. Or I can't even run example Planetside 2...
And I noticed this .exe problem when I tried to run the latest Battlelog plugin, it simply did nothing.
Firstly I thought I have a virus, although I haven't visited any untrusted sites or downloaded anything random files from untrusted sites. So I ran Full System scan on Norton Internet Security and it didn't detect anything.
After this I installed my drivers again, ran programs on compatibility mode, without any change.
Well I read from the amazing world of the wide web that some people have fixed the "DirectX" problem on BF3 by setting down values of GPU so I opened the good old EVGA Precision X and it said: "Failed to initialize display driver wrapper!"

After all this I did the DxDiag and there was nothing unusual except: "DirectX setup parameters: Not found"

System Information
Time of this report: 3/26/2014, 15:05:58
Machine name: ASUSLEEVI
Operating System: Windows 8.1 64-bit (6.3, Build 9600) (9600.winblue_gdr.131030-1505)
Language: English (Regional Setting: English)
System Manufacturer: ASUSTeK COMPUTER INC.
System Model: G75VW
BIOS: G75VW.218
Processor: Intel(R) Core(TM) i7-3610QM CPU @ 2.30GHz (8 CPUs), ~2.3GHz
Memory: 8192MB RAM
Available OS Memory: 8144MB RAM
Page File: 3505MB used, 8095MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.03.9600.16384 64bit Unicode

DxDiag Notes
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Sound Tab 2: No problems found.
Input Tab: No problems found.

So what could be the problem?
My specs:

Intel® Core™ i7 3610QM Processor
Windows 8.1 Pro
750GB 5400/7200
Nvidia GTX 670M 3GB

Feel free to ask me more information if needed
New member

Interests: Ski Jumping, Developing, Computer Technology
Location: Suomi, Finland


Level 12
check to see if others are having problems with that windows 8 update or just uninstall that windows update
Crosshair IV 1090T 4093.7 - Crosshair V FX - 8350 Batch # 1243PGT 4.422MHz - 4816.08 MHz 1.5v - GSKILL F3-14900CL9D-8GBSR(x2)1087.6 11-12-10 1.5volts - ViewSonic VX2439wm - Acer GD235HZ - SyncMaster P2350 - PowerColor Red Devil RX 480 8GBD5-3DH/OC - Current Mode: 5760 x 1080 - (retired) ASUS GTX660DC2O2GD5 - Nvidia 3D Vision Wired - HAF 932 - Corsair HX850 - Corsair H100i - latest - Day thirteen 60fps - as always I'm powered by

That should teach you not to touch something that is working well... that´s where I stand 😛 Format and never Win update again? xD

oh oh, and... NORTON?????!!!!! You mean Norton Internet Security?!!!! OMFG dude, who on his perfect sanity would have norton installed... Remove that freakin crap from your computer (if you can). Really, just... FORMAT!!!