cancel
Showing results for 
Search instead for 
Did you mean: 

Windows 11 - Can't Turn On Secure Boot

luckybush
Level 7

So I'm trying to play Valorant but Secure Boot State is off and I am unable to turn it on in my BIOS settings

image_2024-02-25_143136079.png

This is the error that comes up and when I go into my BIOS settings it just doesn't let me turn on Secure Boot.

image_2024-02-25_143309442.png

It let me turn on Secure Boot Control but not Secure Boot. I've tried resetting the BIOS to factory settings and it still didn't help. I have an administrator password installed too.

My BIOS version is 319 and my laptop is an ASUS ROG Strix G15 if that helps. I'm not really too smart with this stuff so I don't know what to do and if anyone can help that'd be greatly appreciated.

572 Views
1 REPLY 1

luckybush
Level 7

Edit: I fixed it

So basically if anyone else has this issue you need to turn on Secure Boot Control, then Key Management should show up. When it does, go into that menu and find the setting that says something like "Install Factory Keys" and after doing that it was solved for me, I don't understand why but after I saved and exited and went back into my BIOS settings it showed as enabled and still didn't give me the option to change it so. Valorant now also runs for me.