Showing results for 
Search instead for 
Did you mean: 

Unable to remove AiChargerPlus.sys

Level 7

I migrated to a non-Asus motherboard. I had a very poor user experience trying to get AI Suite software off of my computer for the following reasons:
1. The AI Suite uninstaller refuses to run from a non-Asus motherboard. I believe this is an design bug in Asus AI Suite, and request it be fixed.
2. AI3Cleaner.exe from this forum runs yet upon executing it, it exits immediately, and can I can only see a window frame blink for a split second. Launching it from console adds no further output as to why. I believe this is a bug, and request it be fixed.
3. I managed to manually delete most of the files installed by AI Suite, however there is one important file that I am unable to remove.

The file I cannot remove is: C:\Windows\SysWOW64\drivers\AiChargerPlus.sys
I do not like having worthless (to me) and possibly insecure code loaded in my kernel.

It is easy enough to delete/move/rename the file from Linux or WinPE, however the next boot has my USB ports disabled (no mouse or keyboard).
It becomes necessary to restore the file using RDP (or SSH if enabled) or using a live linux with NTFS support.
It seems to me, that something in the USB driver of my non-ASUS motherboard somehow depends on AiChargerPlus.sys and fails to start.

I hope someone can help advise me on how to remove AiChargerPlus.sys without breaking USB as the only other alternative seems to be reinstalling Windows.

Does anybody know how to further debug the cause of the breakage or USB not starting on boot?


P.S. ccleaner does not help

Level 7
Dear Vittorio,

thanks for posting this issue. Have you already found a solution?

As far as I've read - but not yet tried myself - there are some users out there who just installed a newer or latest version of Ai-Charger, and then unsinstalled it, and everything was gone.

I myself have the same problem, but not due to motherboard-change but only due to windows-update from Version 1803 to 1809!

Seems like Ai-Charger is not completeley compatible with later Win10 Versions...

Anyone else out there who has a solution for this problem (exactly as Vittorio stated it above)?

Thanks in advance and kind regards 2 all ROGers!!!

Level 7

This is what ASUS told me, have you tried it in this order?

- Update the motherboard's bios to its latest version

- Update the motherboard's chipset to its latest version

- If after updating bios and chipset, the customer still receives the incompatibility message from enabling memory integrity, then have him uninstall AI AiChargerPlus and delete AiChargerPlus.sys service. If removing AiChargerPlus disable the motherboard's USB port, then have reinstall the latest chipset driver for this motherboard.