Showing results for 
Search instead for 
Did you mean: 

Ryujin II 360 not showing in Armoury Crate Windows 11

Level 8

I've installed the Asus AIO Ryujin II 360 on the Asus z790 Hero on Windows 10 and it worked prefectly.

But I had to reinstall windows so I went with Windows 11, and now after installing all Motherboard drivers, and all windows updates. I've then installed Asus Armoury Crate, and on Devices only shows 2 Items: ROG MAXIMUS Z790 and FAN Xpert. There's no Ryujin II 360.

I've installed the Armoury Crate and Uninstalled it 3 times and all times the Ryujin would not show on Devices. I know its installed well, and connected to an internal USB. The only thing I've changed is the operating system from windows 10 to Windows 11.

Please if anyone knows a why to fix this, let me know. Thanks in Advance.


Level 7

same issue here.  mine was working fine and then one day this week the Ryujin II just decided to stop detecting in armoury crate.

Level 8

Well, for me I found out that where I connected the Ryujin II on the motherboard stopped working, so I swapped to the other USB 2 connector that was next to one I orginally used, and it started working again.

I just tried doing this and unfortunately the issue is still happening for me 

Well, when this happened to me the screen was dark, so if its dark it might be the USB is not powering. The other option is to use the USBs from the back panel with an adaptor to use the one from the AIO so u can put the cable connected outside going to the inside. But if the screen is on and the Armoury is not registering the AIO, it might be a problem with either the drivers or some other hardware on the AIO box... that would be my guess...

The screen on the Ryujin II is showing the default animation in a constant loop for me. It’s not an issue of power but more an issue if broken armoury crate software. 

Well, if the screen is on, it might be the Armoury crate playing up. Try to uninstall it with the special tool to uninstall it, reinstall it and see how it goes. Check the Armoury crate section of this forum, they might have a better idea on how to help you.

Thanks.  I tried uninstalling and reinstalling multiple times but no success.  I'll check the armoury crate section of the forum like you said.

Level 8

Well, I discovered that the USB 2 port on the motherboard where I had connected the Ryujin II had ceased functioning, so I switched to the USB 2 port next to the one I had originally used, and it began functioning again. mario games

I tried switching internal usb ports and am still experiencing the same issue