cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Gaming Center GL703GE

tap002
Level 9
After NVIDIA 418 driver update and latest windows updates Gaming Center will open for 1 second then close. If I uninstall then reinstall it will work until I shut down or restart. Repair does not work. If I change settings right after reinstall it remembers the settings. ROG Gaming Center Service is running.
4,656 Views
2 REPLIES 2

tap002
Level 9
Discovered that stopping the ROGGamingCenterService allows me to launch gaming center without crashing or closing. As soon as I launch gaming center the service starts. For some reason ROGGamingCenterService running at boot up prevents gaming center from opening??? Once launched, I can open or close as long as I don't restart or shutdown. Gaming center installs two services; ROGGamingCenterService and Intel(R) Extreme Tuning Utility service. By default gaming center runs automatically and Intel runs auto delayed. I set gaming service to manual, I can start gaming center and the services starts, problem solved. BUT, I run as standard user. When I log out of administrator account log in as standard user the gaming "service" does not start even though I launch gaming center as administrator (chicka boom, chicka boom don't ya just love it). Gaming center opens but doesn't read temp or MHz because the service does not start. Any brilliant minds out there have a theory as to why the service running at boot up prevents gaming center from staying open on initial launch???

See Tom Tombroni's reply on my thread. Updating to 2.6.1 (which isn't shown on our PCs' drivers page) fixed it for me.