Showing results for 
Search instead for 
Did you mean: 

ROG Armoury II V3.00.16 [Report any issues here]

Community Admin
Community Admin
Armoury II 3.00.16 is now available.
Manual download here:

Release Notes:
Improved performance
Added support for ROG STRIX FUSION 300
Added support for ROG STRIX CTRL

Execute UpdateInstaller.exe to update.

When reporting issues, please install the latest software and firmware, then provide as much info as possible to help us understand your setup.
Include the following info:
1. PC / Laptop
2. Aura Sync products
3. 3rd-party peripheral, audio, or lighting software
4. Wired / wireless connection
5. Reinstalled Armoury II?
6. Reinstalled Windows?
7. WIndows version & build
8. Previous version of firmware or software that worked as expected
9. Clarify your issue as clearly as possible.
10. Any screenshots of issue
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin
182 REPLIES 182

Level 10
1. PC
2. ROG Strix Z370 - E, Strix GTX 1080, Thermaltake Riing Plus AIO, ROG Pugio, Fusio 500
3. No, only AURA and Armoury
4. Wired Connection
5. Reinstalled Armoury II, current version 3.00.20 Firmware Ver 0153
6. Reinstalled Windows, Yes
7. WIndows version & build, WIndows 10 Pro, Ver 1809
8. Previous version of firmware or software that worked as expected, none
9. I have synced both the ROG Pugio and the Fusion 500. This works fine until the PC is shutdown or restarted. Then the Fusion 500 chooses it's own lighting setting while the Pugio remains as it was set. The only way to change this is to load Armoury, enter the Sync settings, select OFF, Apply, then choose your settings again.
10. Any screenshots of issue

Level 12
strix flare and gladius2. Once system shut down if I tap key or move mouse the leds light up and stay on on the keyboard and mouse. I have to restart computer and then shut down for them to go out again. Any ideas
Maximus XI Formula, I9-9900k, Phantex Evolove X, Seasonic Titanium 850W, Custom loop PE360+SE360 Rad, G.Skill Trident Z F4-3200C14 32g, Nvidia Reference RTX 2080 TI, Samsung 970 EVO Plus 1Tb, Windows 11

Level 10
So I have just done a few days of testing and have confirmed my results.

Strix Z370E - AURA works fine

ROG Pugio and Strix Fusion 500 - Armoury loses sync if shut down. You have to start Armoury each time choose another option, then select your option again.

Same here. The state of the ASUS software is utterly embarrassing, making me regret getting so much within their ecosystem.
It's embarrassing that I have to choose between being able to easily customize my keyboard and mouse functionality and being able to have their RGB sync, let alone sync with the other RGB items connectted through my motherboards headers and RAM. Your software is stuck in the 90s and needs to be seriuosly upgraded.

JimmyH wrote:
Very disappointed with AURA and Armoury, two totally different lighting programs and if you add Fusion Headsets to the mix, it's different again. I am now just researching AUROS from Gigabyte, they seem to have their stuff organised.

Level 8
rog gladius 2 wireless has an issue when turning on pc it is begin with second dpi so i need to click on dpi button to get it back on the first

Level 7
Still Can't Update due to a catastrophic failure.

Changing any settings in ROG Armoury for my headset does not do anything

blind1337nedm wrote:
Still Can't Update due to a catastrophic failure.

Same issue here. I'm still on Armoury 3.00.16 and can't update due the error.

ROG ARMOURY 3.00.26 + ROG FORMULA X + ASUS CLAYMORE = Impossibility to access BIOS pressing DEL or F2 During post. Its needed uninstall Armoury software.

Critic failure...

I have a problem with Armoury 3.00.22, when the PC starts, sometimes it appears the error message in attachment and armoury closes without the possibility to restart it

1. PC
2. Aura Sync products: Asus Maximus X Hero latest Bios, Asus Strix 1070 O8G, Asus ROG Gladius II latest firmware
3. 3rd-party peripheral, audio, or lighting software: Corsair Link, Logitech G Hub
4. Wired connection
5. Reinstalled Armoury II? YES
6. Reinstalled Windows? NO
7. WIndows version & build 1809 BUILD 17763.437
8. Previous version of firmware or software that worked as expected: ALWAYS HAD THIS PROBLEM SINCE I BOUGHT THE MOUSE