cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Armoury II V3.00.16 [Report any issues here]

MasterC
Community Admin
Community Admin
Armoury II 3.00.16 is now available.
78139
Manual download here:
https://dlcdnets.asus.com/pub/ASUS/mb/Utility/ROG_Armoury_v30016.zip?_ga=2.188463912.1459324167.1546...

Release Notes:
Improved performance
Added support for ROG GLADIUS II WIRELESS
Added support for ROG STRIX FUSION 300
Added support for ROG STRIX CTRL

Execute UpdateInstaller.exe to update.

When reporting issues, please install the latest software and firmware, then provide as much info as possible to help us understand your setup.
Include the following info:
1. PC / Laptop
2. Aura Sync products
3. 3rd-party peripheral, audio, or lighting software
4. Wired / wireless connection
5. Reinstalled Armoury II?
6. Reinstalled Windows?
7. WIndows version & build
8. Previous version of firmware or software that worked as expected
9. Clarify your issue as clearly as possible.
10. Any screenshots of issue
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin
462 Views
182 REPLIES 182

shamandgg wrote:
Until today you have not fixed the ALT-TAB bug.
When Armoury is minimised to system tray (not task-bar), i.e. after OS start, try to ALT-TAB and you will notice dead ROG Armoury window appears, but it shouldn't. When selected, nothing happens.

See attached screenshot.


Yes, I created whole new topic (link) long time ago on that one, because it is following with any version. Just had to completely uninstall.. And yes, no one answered there.

XPredator13
Level 9
Latest version bugs my Resident Evil 7 startup. Uninstalling Armoury and using an old version the game lauch normally...

blind1337nedm
Level 7
I cannot open armoury with a custom profile saved on my keyboard. armoury keeps reconnecting my keyboard on me and its difficult to close. i thought this was fixed?


EDIT : Opened armoury by resetting rog strix flare with FN+escape

XPredator13
Level 9
Latest version bugs my Resident Evil 7 startup. Uninstalling Armoury and using an old version the game lauch normally...

MrAgapiGC
Level 13
i read that the spartha dock have a update. but still on 1.00 how i update these since press update and there is no update. ODD i remember have a more recent firmware update.

never mind. i just open the vpn, close the app and open again and there it is. update complete OOD

78600
Learn, Play Enjoy!

Hello,
Not a bug report but more a feature request : at this time when Razer Synapse or Corsair iCUE offer almost infinite profiles creation, i wonder why i am limited to 3 profiles in Rog Amoury II v3.00.16 for my Pugio ?

How to create more profiles ?

(tried to deal with config*.ini files without success)

28BeersLater
Level 7
It looks like my Spatha issues of losing connection after sleep are related to firmware 1.72 as outlined Here...

Currently running Software 3.00.16, Dock 1.32 and mouse 1.69.

It appears to be waking up from sleep again without cycling the power, Time will tell if it is still draining overnight when "sleeping" (I'll assume yes, as I'm on the previous firmware)

I do till have issues with the "power" settings (blinking lights battery percentage and sleep time) not saving/refreshing properly on 3.00.16. I have reported this previously.. but do it "enough times" and the setting seem to stick. - it might just be a refresh issue when cycling through the profiles on screen.
Gotterdammerung: Rampage V Extreme | Intel I7-5930K | 32GB Corsair Dominator 2666 | EVGA GTX 980 SC x3
Kingston HyperX Predator 480GB | Corsair Neutron XT 960GB | Corsair AX1200 | Corsair 900D | EK RVE Monoblock | EK 980 GTX Blocks


GOOSE: STRIX Z390I Gaming | Intel i9-9900KF | 32GB Vengeance RGB 3200 | STRIX Vega 64 | Samsung 970 EVO Plus 1TB x2
Corsair SF 750 | Phanteks Evolv Shift X | EK Z390I Monoblock | EK Strix Vega 64 GPU Block

Sonic Studio still fails to load sometimes. Works when I reinstall the ROG Armoury II V3.00.16, but then it stops working after a while, maybe stops after a reboot.

Using:
PC
Windows 10 Pro x64 1809
ROG Armoury II V3.00.16
Wired connection
No 3rd party light/sound software except for Sound blaster that is used by different device

Asus ROG Swift PG279Q
ROG Gladius II
ROG Strix Flare
ROG Delta

Gigabyte GA-Z97X-UD5H BE
Intel Core i7 4790K 4.4GHz
Gainward GTX 1080 Phoenix GLH
Sound Blaster Z
Corsair 16GB 1866MHz VENGEANCE
SSD 240GB OCZ Vertex 460
Corsair RM 850W 80+ Gold

78715

May I also suggest adding sound profiles connected to specific game lauches? Like I want a specific profile when I start pubg. But when I exit I would load my default profile used in windows mode. This should be high prio feature. Makes no sense that this isnt already added from the start.

28BeersLater wrote:
It looks like my Spatha issues of losing connection after sleep are related to firmware 1.72 as outlined Here...

Currently running Software 3.00.16, Dock 1.32 and mouse 1.69.

It appears to be waking up from sleep again without cycling the power, Time will tell if it is still draining overnight when "sleeping" (I'll assume yes, as I'm on the previous firmware)

I do till have issues with the "power" settings (blinking lights battery percentage and sleep time) not saving/refreshing properly on 3.00.16. I have reported this previously.. but do it "enough times" and the setting seem to stick. - it might just be a refresh issue when cycling through the profiles on screen.


Is a windows issue. Sadly many of the computer systems are wire there. Please pn power settings on windows, disable the sleep and hibernation. In my case i also desable the sleep on armory. having these the battery will not suffer much. i lowe the lights to 50% on the wireless mode and all issues are gone. Well not gone gone since you disable functions.

The odd thing is as many version of the dock are difernt. I have 1.255????? rayos.
Learn, Play Enjoy!

Itzycharles wrote:
Is a windows issue. Sadly many of the computer systems are wire there. Please pn power settings on windows, disable the sleep and hibernation. In my case i also desable the sleep on armory. having these the battery will not suffer much. i lowe the lights to 50% on the wireless mode and all issues are gone. Well not gone gone since you disable functions.

The odd thing is as many version of the dock are difernt. I have 1.255????? rayos.


Sorry I just saw this... No it's not a Windows Issue, I have both sleep and Hibernate disabled anyway, I should clarify by "sleep" I means the mouse.

it is functionality that I require as I work from home, and the PC is on / in use all day. The battery simply won't last the day otherwise
Gotterdammerung: Rampage V Extreme | Intel I7-5930K | 32GB Corsair Dominator 2666 | EVGA GTX 980 SC x3
Kingston HyperX Predator 480GB | Corsair Neutron XT 960GB | Corsair AX1200 | Corsair 900D | EK RVE Monoblock | EK 980 GTX Blocks


GOOSE: STRIX Z390I Gaming | Intel i9-9900KF | 32GB Vengeance RGB 3200 | STRIX Vega 64 | Samsung 970 EVO Plus 1TB x2
Corsair SF 750 | Phanteks Evolv Shift X | EK Z390I Monoblock | EK Strix Vega 64 GPU Block