cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Armoury and Spatha Problems

SirGuren
Level 7
Hi,

I just got a ROG Spatha Mouse. When I tried to set it up using the ROG Armoury software, it did not detect my mouse, prompting me to plug in a ROG Armoury compatible device. I also have a ROG Sica, which the software picks up perfectly. When i upgraded the software to 1.01.19 or later, the software crashes on startup.

I am currently using a ROG G501VW laptop with 16GB of ram, and a 1TB HDD, running on Windows 10 Education. Please advise. Thank you

SirGuren

Update: I've tried running the setup files in compatibility mode, which still did not help.

Update2: I went into debugging mode when Amoury crashed, and according to Visual Studio 2015, the program throws a 'System.NotSupportedException' in mscorlib.dll.
7,725 Views
6 REPLIES 6

Brighttail
Level 11
Unload both the armoury and the download the new one for the spatha that just game out. I think it is version 1.01.27. There is also a version the the armoury software you can find if you look up the asus claymore which is like 1.01.23. Give those a shot.

After uninstalling the oldsoftare, restart the computer plug in the mouse directly using the usb port and install. HOpefully you'll get the mouse recognized and you'll have to update your firmware. From there plug the mouse into wireless mode and update that firmware as wel.
Panteks Enthoo Elite / Asus x299 Rampage VI Extreme / Intel I9-7900X / Corsair Dominator RGB 3200MHz

MSI GTX 1080 TI / 2x Intel 900p / Samsung 970 Pro 512GB

Samsung 850 PRO 512GB / Western Digital Gold 8TB HD

Corsair AX 1200i / Corsair Platinum K95 / Asus Chakram

Acer XB321HK 4k, IPS, G-sync Monitor / Water Cooled / Asus G571JT Laptop

Bahz
Level 12
Yes, I recommend you try what Brighttail recommended. Currently the Armoury software is being improved and before there was a bug with the earlier versions where if you tried updating the software through live update it would not update properly. Please uninstall the software and make sure to download and install the latest software from the product support site.

Crasje
Level 12
Guys, maybe you know... I do see the mouse in the armoury but I can't synchronise it via Aura with my other Aura compatible devices (for now only my Motherboard and 1 RGB strip, any suggestions on how to synchronise?

Cooler Master Silent Pro Hybrid 1300W ATX
Asus ROG Maximus Z690 Extreme
Intel Core i9-12.900k
ROG Ryujin 360
Corsair DDR5 Dominator Platinum RGB 2x32GB 5600Mhz
Samsung 980 PRO 2TB M.2 SSD (2x)
Seagate Firecuda 1TB
ROG RTX3080-O10G-Gaming
Monitor 1: ROG STRIX XG349C
Monitor 2: Samsung HDTV T27D590
ROG Claymore
ROG Spatha X
ROG Balteus Qi
Windows 11
😉

Crasje wrote:
Guys, maybe you know... I do see the mouse in the armoury but I can't synchronise it via Aura with my other Aura compatible devices (for now only my Motherboard and 1 RGB strip, any suggestions on how to synchronise?


The Spatha can only synchronize if it's plugged in and not in wireless mode

Crasje
Level 12
Thank you

Cooler Master Silent Pro Hybrid 1300W ATX
Asus ROG Maximus Z690 Extreme
Intel Core i9-12.900k
ROG Ryujin 360
Corsair DDR5 Dominator Platinum RGB 2x32GB 5600Mhz
Samsung 980 PRO 2TB M.2 SSD (2x)
Seagate Firecuda 1TB
ROG RTX3080-O10G-Gaming
Monitor 1: ROG STRIX XG349C
Monitor 2: Samsung HDTV T27D590
ROG Claymore
ROG Spatha X
ROG Balteus Qi
Windows 11
😉

dzinch
Level 7
Asus Spatha and Armory 2 Bug

Mouse doesn't remember the keymap and macroses shortcuts assign to it.

Reproduced on:
Windows 10 x64,
ARMOURY 2 Version: 2.05.01
Dock Firmware Version: 1.32
Mouse Firmware Version: 1.69

The behavior

Steps:
1) Open ARMOURY 2
2) Select Profile 1
3) Open BUTTONS tab
4) Chose Side view
5) Click to one of 7-12 buttons
6) In drop-down list to seletec Keyboard Function
7) In "Button7 change to be:" Input: ctrl+alt+9
😎 Click to "Ok"
9) Click to "Save"
10) Minimize a ARMOURY 2 window
11) Reboot PC
12) Repeat 1-4 steps

Result:In all Button specified Mouse Function: Disable

Expected result: In all Button specified what was set before, for example step 6-7

Solution:Downgrade ARMOURY to 1.02.26 version