cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with RX 580 STRIX O8G & Ryzen 7 1800X

Enterpriser1995
Level 7
(Well, sorry if this is my first post and I didn't make one to talk about myself a little, I promise I'll do one soon)

Hey.
I'm here to talk about my seemingly infinite issues, either software-sided, or hardware-sided.

So I got this almost new build, details are the following:

  • Motherboard: RoG CrossHair VI Hero
  • RAM: Corsair Vengeance @2400Mhz 2x8GB
  • CPU: AMD Ryzen 7 1800X (For now clocking @3600MHz)
  • GPU: RoG STRIX RX 580 O8G [for now the values are: MemClock @ 2000 MHz (as stated by AfterBurner) or @8000 MHz (as stated by GPU Tweak II) and CoreClock @ 1360 MHz
  • PSU: LEPA B1000-MB
  • HDDs: Seagate Barracuda 1TB, Seagate Barracuda 500GB, 1
  • SSDs: None, I'm still working on it.
  • Cooling solutions: Cooler Master MasterLiquid 240
  • Other cooling solutions: 1 120 fan in the front, 2 120 fans on the left side, accompanied by one 200mm fan above them, GPU height.


What happens?

Well, anything you can imagine.
First of all, reported temperatures are different on BIOS, Ryzen Master and SpeedFan.
Then, it seems like the GPU was the last strike this PC could receive.
After I installed the GPU things started to go crazy, benchmarks reporting 60% less performance on the GPU, random freezes with GPU Tweak opened (something like framerate lag but just longer?), and i couldn't edit values inside GPU Tweak, every try to apply the value would put them back to minimum. Then I decided to format it, and it got even worse.
(I had to install AfterBurner at this point, pay close attention.)
So, my card has 0db Technology, but GPU Tweak has no switch for it, so i thought it would just behave like it used to with 0db on.
AAAAND I've never been so wrong.
I just started fooling around with benchmarks, to my surprise they went from a 10.000 (3DMark Fire Strike) to a solid 12.000, that's a 20% increase. After that, i kept benchmarking just to be sure, discovering that my card, over time, and i'm talking about a few hours, got put back to 8000.

Then, tired, i got to my IT Support Laboratory where I used to work, and worked with two other people.
We benchmarked it a little again, just to be sure it wasn't PSU's fault.
Well, it wasn't, but we've noticed fans on the GPU were kept stopped for no reason, even after the card reached a whopping 81C.
So we installed MSi AfterBurner, and it worked, for a little while. after 30 minutes to 1 hour the card had the problem again.
We discovered that drivers from AMD Updates (Crimson Live Updates) were taken as Windows Compatibility drivers, pushing my card back in performace.

And now i'm stuck here, with no driver updates, nor control on my fans, is there a solution, or something like that?
4,109 Views
2 REPLIES 2

Flint018
Level 7
I had the same problem with RX 580 8GB TOP, seems like the GPU fan is not optimize yet overclocking software, stuck with AMD software.

Flint018 wrote:
I had the same problem with RX 580 8GB TOP, seems like the GPU fan is not optimize yet overclocking software, stuck with AMD software.

Yeah, i solved the problem by using MSi AfterBurner, got it to work after a hundred reboots maybe 😛
I overclocked my CPU to 4025 MHz.
But then another problem got up, i chosen to update EZ Update since there was a newer version available, and it brought my CPU back to default values, also, AURA stopped working properly, meaning that it was just stuck in the color setting screen, without applying anything.

So i tried updating both the GPU Aura and the Mobo AURA, and well, i get a crash message every time i try to open Aura right now.
Also, here's the report.

https://drdump.com/UploadedReport.aspx?DumpID=17674980&SecondVisit=1

What's that X99 guys? I thought CrossHair VI Hero had X370...

Also, maybe instead of adding new features to AI Suite you could maybe speed it up a little bit? Come on, i have a decent pc, how comes it doesn't open fairly quick at least?