Showing results for 
Search instead for 
Did you mean: 

Problem installing Armoury Crate

Level 7
Greetings, I am new to the forums and am having trouble trying to install Armoury Crate.
My problem started a few weeks ago when Aura Sync stopped working with my Prime Z390-a motherboard.
It had been working fine since I built the computer in January and there has been no changes to the computer apart from Windows updates..
In Aura the motherboard was greyed out and could not be changed.
I uninstalled Aura using 10bit Uninstaller so there were no files left over and went to download Aura again but found it has been replaced with Armoury Crate.
I went to the ASUS site and downloaded Armoury Crate for Windows 10 64 bit.
The zip file came down fine and unzipped to ArmouryCrateInstaller_3.0.9.0.exe .
When I click on the installer file there is a chime and the window comes up asking “do you want this app to make changes to your device?”
When I click yes it does nothing but takes me back to the installer file again.
I have never had this problem with any other installation files and am finding it frustrating in the least.
I do not have any other RGB software.
I have tried uninstalling Armoury Crate and reinstalling but it will still not install.
I went to ASUS support and was just referred to links I had already checked out. After I went back to them and said I had already checked those links they told me to report it on the ROG Forum — ASUS Software.
Below are the specs I was asked to list.

Motherboard: ASUS Prime Z390-A.
Processor: Intel Core i5-9600k.
BIOS Version: 1704.
OS: Windows 10 64 bit Home.
Memory Kit: Team T-Force Delta II RGB 16 GB DDR4 2666.
Graphics Card: ASUS GTX 1060 Turbo.
Mouse: Steel Series Rival 3.
Keyboard: Corsair Vengeance K60.
Cooling Solutions: CPU One Noctua NH-U12S 120 mm fan, front case three Deep Cool RF120 mm RGB fans, rear case one Phanteks 140 extractor fan.
No Aura software.
No other lighting software.

One: Files as downloaded.
Two: Installer file.
Three: Windows app change request.
Four: App change request does nothing but goes back to original file.
Five: Bios advanced screen as requested.

Any help or suggestions would be appreciated.


Level 7
What did you find out? I can't get the armoury crate to install from winrar? I uninstalled and tried several times?????
As you did, I have removed all RGB programs and no luck.......
Anybody know how to install aura, just AURA or have a link????