cancel
Showing results for 
Search instead for 
Did you mean: 

Poor speeds on Samsung 980 pro Nvme pcie 4.0

saadiq7
Level 7
Hi guys/gals,

I have tested my 2 1tb 980 pro nvme's with crystaldiskmark & I get pretty close to advertised speeds.

Also tested with Samsung Magician & get even better results closer to advertised specs.

However when I copy a 10gb file from one 980 pro to the other the max speed I'm getting is 700mb/s. It fluctuates between 400-700mb/s.

Do you know what's wrong? Am I missing a driver? I've installed all the drivers from my Asus motherboard support page.

It can't be a faulty drive as both drives are doing the same thing. I'm using Windows 11. I've updated all drivers from Asus & from this site from MoKiChU

Oh one more thing, the default windows copy handler wasn't working 100%, so I installed the latest version of teracopy. Please help?!
MB: Asus Z690 Maximus hero
RAM: 2x32gb g.skill Trident Z 5600mhz ddr5
NVME: 2x Samsung nmve 1tb 980 pro
HYPERCARD: 2x Crucial P3 4TB nvme
CPU: i9-13900k
GPU: Gigabyte 3080 Ti Eagle OC
COOLER: Gigabyte waterforce 360
CASE: CM TD500 mesh
PSU: Corsair HX1000
1,351 Views
4 REPLIES 4

saadiq7
Level 7
Enable VMD Controller - ENABLED
Map PCIE Storage under VMD - DISABLED
Map SATA Controller under VMD - DISABLED

NVME's are in M.2_1 & M.2_3 slots.

Rapid Storage Technology - DISABLED
MB: Asus Z690 Maximus hero
RAM: 2x32gb g.skill Trident Z 5600mhz ddr5
NVME: 2x Samsung nmve 1tb 980 pro
HYPERCARD: 2x Crucial P3 4TB nvme
CPU: i9-13900k
GPU: Gigabyte 3080 Ti Eagle OC
COOLER: Gigabyte waterforce 360
CASE: CM TD500 mesh
PSU: Corsair HX1000

MoKiChU
Level 40
Hi,

If you have benchmarked your SSDs and these are at the specs speeds, there is no drivers issue (moreover, but if there was really a problem with the drivers, these SSDs controller use the Microsoft built-in drivers, there are no other drivers for these SSDs), your issue seems more software related (check the impact of your anti-virus on the file copying for example).

MoKiChU
Level 40
Hi,

If you have benchmarked your SSDs and these are at the specs speeds, there is no drivers issue (moreover, even if there was really a drivers issue, this Samsung SSDs controller use the Microsoft built-in drivers, there are no other drivers for this controller), your issue seems more software related (check the impact of your anti-virus on the file copying for example).

saadiq7
Level 7
Ok, I've sorted the issue out. Or at least it was sorted but I was running the wrong copy handler prorgram.

When I installed my windows, the default copy handler would copy but not hide after copying, so I installed teracopy.

Also, the settings/network/etc menus would open minimised. I then ran a sfc scannow, so that was sorted. I didn't check to see if the original copy handler was fixed too.

So teracopy was slow (765mb/s) write, but after uninstalling it, the default one writes at (3.2gb/s) & closes when completed. It seems the original sfc scannow sorted that issue out.

So yes I'm glad it's all sorted now.

Thank you for the suggestions all!
MB: Asus Z690 Maximus hero
RAM: 2x32gb g.skill Trident Z 5600mhz ddr5
NVME: 2x Samsung nmve 1tb 980 pro
HYPERCARD: 2x Crucial P3 4TB nvme
CPU: i9-13900k
GPU: Gigabyte 3080 Ti Eagle OC
COOLER: Gigabyte waterforce 360
CASE: CM TD500 mesh
PSU: Corsair HX1000