cancel
Showing results for 
Search instead for 
Did you mean: 

New Nvidia drivers makes iCue not recognize anymore ASUS Motherboard and GPU (or not?

THEMAGICJULES
Level 7
Hi all,

I’ve installed the last release of Nvidia drivers and I believe that makes iCue not recognize anymore my ASUS motherboard and the GPU; moreover now in the dashboard, it is saying Nvidia RTX 3090 and not ASUS Rog Strix 3090. I’ve tried a clean reinstall of Armory Crate (total rubbish) and iCue but still; the only thing left is to rollback the Nvidia drivers (I would like to don’t do that).

Any suggestions?



iCue ver. 4.24.193

Nividia ver. 516.40

CRAP Armoury crate ver 5.1.4.1 (should be the last ver.)
413 Views
34 REPLIES 34

ahfoo
Level 13
For my system, when boot it will not shown up in iCUE even the latest version. What I do was to end quit iCUE for awhile and click launch iCUE (not iCUE shortcut) and wait for awhile the mpbo and Asus GPU appear again. You may tried that.

sehlat
Level 10
There's also another issue. If you install a game that requires Easy Anti-Cheat software, you have to turn off the lighting service in Services to be able to run the game (several of my games use this POS software too). That disables Aura so you can't run your lighting effects. So right now, mine is turned off and all I have running is the default RGB lighting that Live Dash controls. Pretty, but it's not custom. I also totally disabled iCue as well, so it needs updating to even work with the newer drivers if I want it to work. 😞

https://steamcommunity.com/app/674020/discussions/0/1743355067137911377/

Minh_Le
Level 7
With iCue v4.29.203, everything is working properly.

Minh Le wrote:
With iCue v4.29.203, everything is working properly.


I confirm that my GPU (Asus RTX3080 TUF) is showing up again in iCue after the 4.29.203 update!

Minh Le wrote:
With iCue v4.29.203, everything is working properly.


Just updated to latest iCue and all working for me - good news! :cool:

edit - mine is an asus tuf gaming 3060 Ti