Showing results for 
Search instead for 
Did you mean: 

MyASUS white window

Level 7
Hi, everybody! Alex here!
I'm a proud owner of a ROG Zephyrus s17, which i personally use as an alternative mobile gaming/workstation setup since i moved temporary in Duesseldorf.

While what concerns gaming works flawless and gives me nothing to complain about, i'm experiencing a very frustrating issue with myASUS application.
It would be nice to have an integrated "asus" way to control battery level limits, but myASUS simply never worked.

I launch it and loads with normal animation, then turns in a white window, which is completely useless. I've tried virtually everything to fix it, performing reinstallations with registry cleaning and so on.
No matter which version of asus interface i have (V3 currently), it simply stays white despite of everything i tried. Up to date i haven't found a solution on the web describing my issue. There's apparently only one guy on reddit, which posted a screenshot of my exact problem but none found a solution.

Does anyone know a solution to this or has anybody experienced the same issue? Any workaround?

Level 7
Ok, i figured it out what caused my problem.
That's a conflict of permissions/ownership of the app executable itself.

As long as i launched the shortcut i got from microsoft store i got the white window, and i tried then to gain permission of the executable itself, which is in the following path to be found:
C:\Program Files\WindowsApps\B9ECED6F.ASUSPCAssistant_3.0.19.0_x64__qmba6cd70vzyy\MyASUS

You have to get full ownership and access to WindowsApps folder.
Here's what's strange: when i launch the executable directly, it works. when i launch the microsoft store shortcut, i get white window.

I simply replaced the shortcut, and it works now without problems.

It was difficult to find a solution on the web due to the name itself "MyASUS" outputs in google thousands of useless thread. That's simply too generic.
Winzoz works always the same way and when no other cause seems to justify a software malfunctioning, check the original path and mess with ownerships.

Thanks for reporting back for others that might find this.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…