cancel
Showing results for 
Search instead for 
Did you mean: 

My Gaming Center (2.5.7) crashes seconds after opening

atheoAng3l0
Level 7
I've tried reinstalling it several times with the installer from my NBPC's (GL703GE) drivers page. After rebooting as asked, GC would work fine, but after I turned my PC off and back on or restarted it, the issue would resurface.

The only working solution I've found is closing ROGGamingCenterService and then restarting it by opening GC. Haven't a clue how or why. I've automated this with a batch script that runs at startup.

Preventing the service from running at startup and then running it manually didn't fix it nor did restarting it via Services.msc.

If there is a better solution, lemme know.
683 Views
5 REPLIES 5

tap002
Level 9

Tom_Tromboni
Level 8
I have an ASUS gaming notebook. This gaming (2.6.1) center works absolutely well with the last Windows Update.
It is the latest version

https://dlcdnets.asus.com/pub/ASUS/GamingNB/GL503GE/ROG_Gaming_Center_V2.6.1.zip?_ga=2.216545238.117...

Best regards Tom

Tom Tromboni wrote:
I have an ASUS gaming notebook. This gaming (2.6.1) center works absolutely well with the last Windows Update.
It is the latest version


Hey, that did the trick! Thanks!

Asus should update my PC's drivers page. There's clearly something wrong with GC 2.5.7.

ROG gaming center 2.6.1 is now available download from GL703GE support page.
I've installed it and it is working with XTU and bios 318.
Two anomalies:
1: RGC will not launch when running as a STANDARD USER. Had to change the short cut target to "C:\Program Files (x86)\ASUSTek COMPUTER INC\ROG Gaming Center\LaunchROGGamingCenter.exe"
2: HDD percentage usage meter not working, but that has not worked for me for well over a year now.

tap002
Level 9
I to got 2.6.1 working on my GL703GE. Installed bios 318 last night. Out of curiosity I uninstalled 2.6.1; installed 2.5.7 and now it works.