cancel
Showing results for 
Search instead for 
Did you mean: 

HPU issues with 1304 bios

Undertoker
Level 9
hi guys
im running an asus hero z690 and 12900k with a strix 3090 OC

i am currently using bios 811 because whenever i go to either 1003 or 1304 i get drastic gpu slowdown, i score literally about half in firestrike solely on my gpu , the rest of the system is fine and as a result of this gpu issue it ruins my fps in all games - im not sure why m its only when i update from 811 bios, 803 is also fine with no issues but if i upgrade to 1304 i get half the gpu performance, i cannot use the bios in this state, so im sticking with 811
Dont get me wrong my pc will run, but its as slow as hell and benchmarks show the gpu performance is less than half what it should score only with both 1003 and 1304 bios, but performing as it should on 803 and 811 bios...

The GPU performance is ruined with 1003 and 1304 bios, ive tried running it at defaults and also trying iy with and without the resize bar turned on or off , it makes no difference, so i have to go back to 803 or 811 and its then fine

is anyone else habing this issue with either 1003 or 1304 and gpu performance problems ?
I9 14900K >ASUS ROG Strix RTX 4090 OC Edition
ASUS ROG MAXIMUS Z690 EXTREME EATX Motherboard
ASUS ROG PG35VQ @ 200mhz in 3440x1440
Trident Z RGB 64GB DDR5 @ 6400mhz
Samsung 980 EVO Pro M.2 x 5 off
NZXT Z63 Kraken AIO CPU Cooler
NZXT H700i + Hue 2 (Pubg Edition) - Heavily modified
ASUS ROG THOR 1200w PSU
Corsair M65 RGB Mouse
Corsair K95 RGB Keyboard
899 Views
1 REPLY 1

VroiteR
Level 8
Undertoker wrote:
hi guys
im running an asus hero z690 and 12900k with a strix 3090 OC

i am currently using bios 811 because whenever i go to either 1003 or 1304 i get drastic gpu slowdown, i score literally about half in firestrike solely on my gpu , the rest of the system is fine and as a result of this gpu issue it ruins my fps in all games - im not sure why m its only when i update from 811 bios, 803 is also fine with no issues but if i upgrade to 1304 i get half the gpu performance, i cannot use the bios in this state, so im sticking with 811
Dont get me wrong my pc will run, but its as slow as hell and benchmarks show the gpu performance is less than half what it should score only with both 1003 and 1304 bios, but performing as it should on 803 and 811 bios...

The GPU performance is ruined with 1003 and 1304 bios, ive tried running it at defaults and also trying iy with and without the resize bar turned on or off , it makes no difference, so i have to go back to 803 or 811 and its then fine

is anyone else habing this issue with either 1003 or 1304 and gpu performance problems ?


i having the same trouble here with 1304.... how i do to go back to 811 bios? ty