Showing results for 
Search instead for 
Did you mean: 

GPU Tweak Opens Window on Desktop

Level 9

So I have being using GPU Tweak for a while now without any issue. After updating to the latest version though now every time I open a program or even switch between HDR on/off GPU Tweak opens a window on my desktop if it is running in the background instead of staying minimized to my task tray like it always has in the past. I can't find any setting that has to do with it though I assume I am missing something simple. This interferes with various programs and would be great if there was a way to stop it from acting this way other than simply not running it.


Excellent news thank you!

Side question: Does GPU Tweak III support auto updating? I've always had to remember to visit the website to find updates. 

Super Moderator

Hi all,

GPU Tweak is now available to download

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Thanks for posting the link. GPU Tweak III hasn't popped up during Display Handshake event, since installing the update. 

Thank you for the heads up and I can confirm too that the pop up issue is now gone.

The OSD is completely broken in this version. It will not enable no matter what I do, and when I forced with the toggle switch in the app, whatever game I am running crashes. Anyone else? I would really like to use this program but there are always consistent bugs that Afterburner just doesn't seem to have. 

I believe you, but I myself am having seemingly no issue. I don't normally use the OSD but I tested it out and enabled it through the app with various games and launchers that I have and again there was no problem. That is however on my system and different GPU drivers, OS's, different versions of the same OS etc. can all create issues, but I have not experienced this.

Please ensure no other apps open are polling the GPU and try disabling any other overlays and report back. OSD behaviour seems normal for me currently.

Can you give me an example of a game that crashes?

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Level 10

Ok I did a complete uninstall and re-install of the latest version and now it works fine! Very odd. On the first install, every game where I tried to enable the OSD, the game would slow down massively and then crash. Maybe I just found a weird bug. Thanks for the replies!

Glad you found a simple fix.  🙂

Level 9

Hello guys, I saw someone mentioned monitor opening itself even check box is unchecked, after some reinstallation with clean isntall there was pop up some issue about LANGUAGE XML fail. Using win 11 (updated) with czech language. Hope I am asking on correct thread. Thank´s for any help (fast boot disabled)