cancel
Showing results for 
Search instead for 
Did you mean: 

GPU Tweak III Hard freezes my PC

Morxgr
Level 8

Hi everyone.

I own an Asus 4070Ti TUF Gaming OC since February

Performance, temp, noise wise, it's all fine and I'm pleased with my purchase.

Right when i got the card, i installed GPU Tweak III so i can set my own fan curve, a tad more aggressive than stock one.

Since the very first weeks of usage, I was getting hard freezes while light system load or YouTube playback.

While playing a pretty light game of League of Legends, i mostly had crashes when the game ended and client came up after exiting the match. Client consists of a front-end with animations and some YouTube videos ready to be played. (mentioning that for a reason, see below). A few times, it crashed while in-game also! Mostly though, when exiting game.

While watching YouTube video on MS-Edge or Firefox.

Crash is not immediate, it only progresses step by step and system is rendered totally unusable in a matter of 10-20 seconds.

First, buttons of applications become unresponsive. I cant shut down any window i have open, some of them close. At the same time, YouTube video is "buffering" with audio being played. Cant close the tab, cannot open a new one.

I can click system tray, but nothing happens. Start -> shutdown is clickable but doesn't do anything.

Task manager comes up but doesn't render any elements. Caps lock is turning on an off, mouse cursor moves around.

I have to press reset or hold power button when last sighs of life are gone. Caps lock eventually stops working, mouse freezes and system is fully crashed with a static image. Tried to turn monitor off while on static image, when it turns on again, i have no signal.

NO Windows event viewer log entries, in any category regarding the crash, apart from an unexpected shutdown or power loss which is normal considering that me myself pressed the reset button or force powered it down. No dumps either!

After many many Nvidia driver releases, situation is the same. Since 1st 40 series one, up to the latest one, tried all of them.

Yesterday, after a month of having GPU Tweak uninstalled having got rid of that crash behavior, i reinstalled it just to get the problem i described above, in less than 10 hours!!

Is it a known issue, does anybody else have encountered this?

Today, i uninstalled it and i'm pretty sure it's going to be fine again.

2,170 Views
10 REPLIES 10

Morxgr
Level 8

Totally forgot to add my system specs:

Motherboard: Gigabyte Aorus elite v2 B550 rev1.0

CPU: AMD Ryzen 7 5800X3D (tried a 5600x with same results!)

Memory: Gskill Ripjaws V 2X8Gb 3200mt/s XMP on and OFF

GPU: Asus RTX 4070Ti Tuf Gaming OC

PSU: Corsair RM1000X & 12vhpwr cable properly connected (No red light or such)

Nvme: Samsung 980 Pro (tried with 970 Evo plus)

 

I also tried HAGGS on / off

REBAR on / off

Pcie operation mode to 3.0 and 4.0

Tried an older PSU (corsair TX750M)