Showing results for 
Search instead for 
Did you mean: 

GPU Tweak 2 still not installing

Level 7
When I launch the installer it asks me "Do you want to completely remove the selected application and all of it's feature?".

I click on and it pops up another message "Error: -1605 This action is only valid for products that are currently installed."

I have gone through the registry manually and with CCleaner and I still get that message.

I did have an older version installed (whatever came on the install CD). I uninstalled it and then tried to install version and have been seeing this problem ever since.

Any help would be appreciated.

Level 13
Rocket do u still have a version of Tweak installed? If u do open CCleaner in tools go to uninstall , click on GPU Tweak , then Repair , then uninstall Tweak. then try installing the version u want . if u do not have Tweak installed there still some files form another version somewhere. I use msi afterburner . as I cannot trust the Tweak Installer .

do u have a restore point before u made changes ? if u do go back to that point and use CCleaner to uninstall Tweak

Level 7
No version installed. Removed traces using ccleaner and went through the registry manually. No restore point from before.

Level 7

Did you check GPU tweak 2 performance rate when you encountering with this issue.

Talk: Instapro