Showing results for 
Search instead for 
Did you mean: 

GNU+LINUX user new to ROG

Level 7
Hi Ladies and Gents,

Its a pleasure to meet you all, in this most auspicious community of geeks and gamers.

I had thought, when it became clear to me because of need and desire that a new notebook was imminent, Dell's Alienware series could furnish the ever widening gap between work and pleasure of my experience with the MacBook Pro 6,2 I'd been gifted just over three years ago. The problem I have with Dell, just as I have had with car manufacturers whose parts engineering leaves their beaten path, is the infuriating encumbrance of proprietary interfaces between disks and the mainboard. It could be that Dell has since left the practice behind after I'd given up my Inspiron 1720. But having spent over $60 USD on a bit of plastic and metal teeth to expand a second drive bay, I wasn't encouraged to try another Dell despite the magnificent specs of their performance laptops.

I also have a delight in legacy hardware, and like to refit old laptops that cross my path. I had been looking for a good deal on an ASUS CoreDuo on which to hack on the sideb (but took an ACER which was an exact duplicate of the one I use as a server in my home office). ASUS' reputation for quality ingrained itself in my imagination, and whilst browsing for a computer that could be both workstation and playstation, I spied the g750 series, which I verified had eight thread i7s, a newish nVidia adaptor, and at least 16GB of RAM. So when my MacBook's backlight automatically shut itself off again a week ago Friday, a sale flier from my favorite local wholeseller I'd seen in my email stood out in my mind. So I crashed my laptop, restarted, and once online again, I looked for their best offer. There was only one g750jh left at any store, in the city branch. It had been on display, but in mint condition, so I hopped in the car and took a drive.

I came home with what might be the most exciting computer I'd ever purchased outright on a whim.

The Setup:

winDOS 7

First boot reminded me with sudden crushing force how much I despise being asked to register with a company just to use my own computer. So I skipped the login went directly to the BIOS. I don't need SecureBoot, so I disabled it. I needed to boot from optical disc, so I enabled CSM. I selected the BD drive and restarted. First whoopsie, winDOS 7 can't install to a GPT partition. Unfortuately I didn't check to see that I could probably have started an in-place upgrade of 8 to 7 by using the EFI console, and instead use my Gentoo minimal environment to repartition the OS disk with an MSDOS label. Second whoopsie, the uEFI boot was broken, and console doesn't work, either. Worse still, nothing else was recognized by the BIOS for booting. Grrrrr.

There is a menagerie of online tutorials about managing uEFI builds on ASUS g750jh, but I'm really cared about balancing boot speed vs complexity vs TTL. Five minutes later, I wiped all the disks, disable the incredibly fragile striped RAID on the dual 256GB SSDs, and enabled Launch PXE OpROM.

After installing winDOS 7 on one of the SSDs, and less than a day of total ownership, and I had to get out my screwdrivers and pop the backpanel to remove the 1TB HDD. You see, winDOS wants to put its 100MB system partition there rather than its SSD no matter what I did while the disk was installed. Reinstalling winDOS without it confined the system partition with the OS on my SSD. I also left the HDD out until I'd completed TrueCrypting it, too, just in case.

There are a lot of missing drivers for winDOS. The nVidia adaptor is most obvious (and expected), but neither the ethernet nor WLAN adaptors worked either. I spent an hour or so getting drivers, mostly directly from ASUS, and installing them. There are still a few devices with yellow question marks, but I can live with that for now. I get tired of looking at winDOS unless there's a really good reason to have to be there, so I start installing Gentoo.

Gentoo GNU+Linux

I love building new Gentoo systems. Especially when its something as important as the computer I'm planning to do everything with afterwards. I only get the opportunity every couple of years. Because of a number of break-ins at my office building, I've been crypting everything. So I start by luksFormatting the other SSD, and luksOpening it. I make the mapper device a PV, then put my system VG on it. Then I start making LVs for the usual suspects {/,/usr,/var,/tmp,/opt,/var/log,/var/tmp,/home,/home/}. I put /boot on a USB disk, and exploded stage3 on that filesystem, following the handbook from there. I installed a custom GRUB menu.lst/grub.cfg to support booting from a crypto root. For those who'd like to know, here is the special sauce:

kernel /boot/kernel-genkernel-x86_64--gentoo root=/dev/ram0 real_root=/dev/mapper/sys-root crypt_root=/dev/sd*? cryptdevice=/dev/sd*?: dolvm ro

...replacing <> braced items and device names with the appropriate values. I'm currently using kernel 3.12.9 because nVidia's binary drivers will not install unpatched on 3.13x yet.

GRUB wouldn't grub-install to my USB, so I repartitioned it with parted. It then worked. Dunno what that changed, but after that it booted the machine. Success.

Although I have to change boot devices in the BIOS to pick which system to boot, I now have a completely encrypted machine dual-booting winDOS 7 and Gentoo GNU+Linux. As I discover how to get more things working, I will post them here.

Things still not working:

  • Toggling the trackpad, disable while typing.
  • Changing keyboard brightness, or disabling light.

Current issues:

  • ttys are completely black if backlight is changed via xbacklight, and X is exited/shutdown/crashed.

Level 7
Reserved for updates, tutorials, etc etc