Showing results for 
Search instead for 
Did you mean: 

GL703VM - ROG Gaming Center no longer works after windows reinstall

Level 7
I switched out the SSD in my GL703VM so naturally lost all drivers preinstalled on the previous one that came with the laptop.
Now after a clean Windows 10 install and manually installing ROG Gaming Center, it no longer works - it's not bound to the ROG button, it doesn't detect the GPU/CPU temperature, the touchpad on/off function doesn't work, etc.
I tried 2.1.5 which I found as latest on the ASUS ROG website, and 2.6.1 which I found linked somewhere here in the forums. No luck.

What driver am I missing? Or what may be the problem?

Thank you in advance for your help! 🙂

Level 7
I think the ATK Package V1.0.0060 will be missing.
I give you the download link

Chipset, audio, Intel MEI etc gets my ASUS notebook via the Windows update.

Also try to do all windows updates and look in the device manager if devices were not detected. (yellow question mark)

I hope it will help. Best regards TOM

That was it. Now it works perfectly.

Thank you very much for the quick answer!!