Showing results for 
Search instead for 
Did you mean: 

Error code 5: Access is denied - AsIO3.sys!!

Level 7
I've read all the threads about this error. Looked at video's on youtube and none have resolved this error. I have come to the awful conclusion that this error is generated due to some strange marriage of Asus software that has dependencies on each other.

My rig is a TUF z490 with Wifi, Asus RTX 3090 24 OC and Asus ROG Strix XG27UQ 27" 4K UHD 3840x2160 144Hz HDR DSC Gaming Monitor.

My Asus software installed is ASUS Framework Service, ASUS Motherboard, AURA, Aura Creator, Aura lighting effect add-on (+x64 version) and Aura Service.

All of the above software are the latest versions.

I don't have AISuite or Armoury Crate installed.

The error code 5: Access is denied - AsIO3.sys randomly pops up every hour or so.

Any suggestions to eradicate this error permanently would be appreciated.


Level 13
Malware scan with Malwarebytyes and open CMD admin and ender....... sfc /scannow

I got the same error message during motherboard HAL installation of armoury crate and aura creator setup. Indeed, opening armoury crate i cannot access to the strix z370-f page and configure the connected led strips.
I tried to unistall every asus sw with revo and then i run dism and sfc, but that AslO3.sys is still present in C:\Windows\drivers directory.
So i tried to remove it using windows 10 safe mode and reinstall armoury crate. The message does not show up anymore but armoury doesn't recognize any device.
I'm just wondering how to repair that driver. Does anyone know if there is some setup package that install that driver?
It would be awesome if someone can help me with this without reinstalling windows. Thanks in advance

Level 7
I'm using Tuf b450 plus gaming having the same issue, its about asus and its **** software.
Can't install aisuite so i cant control the fans also aura doesnt recognize my mainboard too.
When i use aura sync with asus tuf gaming m5 mouse after a while mouse freeze so dont but any asus device again like me.

Just don’t by asus again unfortunately I have 4 pcs doing this oven pops up mid games that asi03 code 5 and can control errors All 4 graphs cards have been stuck on pink from the day I bought them spent hours trying to sort it has got to the point that they are now not usable wish I had never bought anything asus due to funds I have been stuck with this for ages the rgb is only for looks Â*but when it’s for kids it’s hard to get them to understand that I can’t afford to do 4 new builds Â*unfortunately we have been stuck with this rubbish for a long time but now we literally cannot use them as error comes up all the time shame as although a few years old still preform good enough for us seems thay are just forcing us to update everything by bombing us with errors all the timeÂ*

i got same issue.. im so piss right now cause i tried all method.. i reformat my PC 3time but not resolved my issue.. now im planning to to change brand cause of this sh!t

Level 7
It should be caused by a registry residue after uninstalling Armoury Crate before, which caused this control to not be installed normally, and it was necessary to clean up a certain registry and driver files of ASUS to solve it.

1) press WIN+R
2) input: REGEDIT
3) path to: Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\
4) find: "Asusgio2" and "Asusgio3" folder in the left tree window.
5) check the right window, remember the [ImagePath], just like mine is "C:\Windows\system32\drivers\AsIO3.sys"
6) delete these two folders "Asusgio2" and "Asusgio3" in the left tree window in regedit.
7) delete these two files "AsIO2.sys" and "AsIO3.sys" in the path "C:\Windows\system32\drivers"
6) reboot your computer, done!!

what you said there is rubbish doe's not work try again this time get it right 

Level 7

Just use Armoury Crate uninstaller from asus site... its so simple...

That works and I can use it, to uninstall it, BUT, I keep getting the AsIO3.sys can't open error code 5 every time I try to re-install even after using the Armoury Crate Uninstall Tool, and turingn off my Anti-Virus program. to try re-installing Armoury Crate(Latest Version

Unfortunately, I keep getting this error, even when I have neither of the two pesky AsIO2.sys or AsIO3.sys

FILES BOTH are located in C:\Windows\System\Drivers after a FAILED Armoury Crate install. They are BOTH gone after I use the Armoury Crate Uninstall Tool. I'm pissed. I did have it installed once.