cancel
Showing results for 
Search instead for 
Did you mean: 

Error code 2: File Not Found - AsIO3.sys!!

Lmnsour
Level 8
Rog Strix Z690 D4 board.

I just updated from Windows 10 to 11 and its a fresh install. Can't run Armory Crate or install AsusAI suite due to no AsIO3.sys file installed. Armory crate installs but doesn't launch. AISuite won't install at all.


Troubleshooting:

-All devices in device manager are installed.

-I tried every step listed in my google searches with no help (most help articles are for Error Code 5).


Questions:

-How do I manually install the AsIO3 drivers?

-Is there something I may have disabled / need to enable in Bios?
17,220 Views
58 REPLIES 58

Yea that kinda sus imo cuz before security was on and suddenly this problem start to happened , maybe just maybe Armoury Crate contains somethin suspicious in latest versions ? or trying to access something isnt necessary ? Really donno but deactivating main security features of Windows 11 just to control fans and rgb alittle too much dont u think?

psikofunkster
Level 9

The feature – Core Isolation & Memory Integrity – is essentially important in safeguarding your computer security, especially preventing those kernel-level exploits that attempt to run malware with the highest privileges. It is recommended to turn it on and have a backup plan for your important data.28 mar 2023

AferriBr
Level 9


1 - I formatted the SSD and installed Windows 11;
2 - I updated Windows with Windows update;
3 - I installed Armoury Crate with Aura Creator option, too slow, it request a download on Microsoft Store but too slow;
4 - It worked without the error message, but my DDR5 memories appeared in Armoury Crate, but they did not appear in Aura Creator;
5 - I Used Ccleaner (registered) and updated all drivers automatically;
6 - I went to Armoury Crate setup and searched there about updating and it listed a memory driver and I updated it.

7 - The memories reappeared in the Aura Creator and everything worked again.

This software has many bugs, how can it list devices in Armoury Crate and fails to list them in Aura Creator? How can ASUS charge a lot for its products and deliver us such poorly developed software.

CoreI9 12th - 64Gb DDR5- Asus Rog Strix Z690-F Gaming Wifi Intel - RTX3070Ti (Asus)  - Bios Version 2305

Bad news, I was continuing to install other programs and the error code 2 reappeared. I followed the steps below and I confirm that it resolved:

1 - Go to Windows Security;

2 - Go to Device Security;

3 - Go to Core Isolation;

4 - Turn "Memory Integrity" off;

5 - Reboot;

Now I'm going to to find out who caused this, as I had just installed Kaspersky Premium and I don't know if it was him or if a microsoft update caused the problem again. I'm going to uninstall Kaspersky and if I have news I'll come back here.

AferriBr
Level 9

After uninstalling Kaspersky and restoring Memory Integrity to On, the program does not show error code 2 and works correctly. Can anyone confirm if you also use Kaspersky Premium as the problem could be related to an update of that antivirus.

AferriBr
Level 9

I found the origin of the problem in my case, I hope it helps them.

It is related to hardware virtualization when activated in Microsoft Windows and Kaspersky at the same time.

 

My computer has the option in the bios activated:

Bios Activated.jpg

And it was activated in the Windows security configuration and now Kaspersky must have also implemented this functionality generating conflict, see the Windows and Kaspersky screens when activated in Windows it says that my system is not compatible on Kaspersky:

Error.png

But when disabled on Windows, Kaspersky accepts and no longer displays the alert. Probably Kaspersky should fix this so that when it is active in Kaspersky it is automatically disabled in Windows so as not to generate a conflict.

OK.png

Aura Creator working again:

AURA OK.png

https://youtube.com/shorts/I9RCZaz_gQU

 

Very interesting and im using Win11 + Kasperky too u might on to something . 

I really thought you were onto something here because I have Kaspersky Internet Security on my system and remember checking the box for using hardware virtualization in its options (and receive a warning claiming that no compatible hardware was detected).

So, I went to the Kaspersky options, removed the checkbox, went back into the Windows Security options and re-enabled the memory integrity option, and finally rebooted. Result => Armoury Crate throws up the Error Code 2 for ASIO3.sys all over again.

At least on my system, disabling hardware virtualization in Kaspersky does not solve the Error Code 2 problem if the memory integrity feature in Windows security is enabled. 🙁 Maybe I should try to temporarily disable Kaspersky in its entirety and test again what happens when re-enabling memory integrity in Windows. 🤔

Anyone else having the Error Code 2 problem and running Kaspersky? Might be interesting to see if other people solve their problem by disabling hardware virtualization in Kaspersky while having memory integrity enabled in Windows or whether that does not work like in my case.

Did u tried the other way ? I mean disable on windows and activate on kaspersky .

Yes, I tried to disable on windows and activate on kaspersky and Armoury Crate works without throwing any error.