cancel
Showing results for 
Search instead for 
Did you mean: 

Error code 2: File Not Found - AsIO3.sys!!

Lmnsour
Level 8
Rog Strix Z690 D4 board.

I just updated from Windows 10 to 11 and its a fresh install. Can't run Armory Crate or install AsusAI suite due to no AsIO3.sys file installed. Armory crate installs but doesn't launch. AISuite won't install at all.


Troubleshooting:

-All devices in device manager are installed.

-I tried every step listed in my google searches with no help (most help articles are for Error Code 5).


Questions:

-How do I manually install the AsIO3 drivers?

-Is there something I may have disabled / need to enable in Bios?
18,444 Views
58 REPLIES 58

Thanks for reporting this. I was not actively monitoring the thread on the Kaspersky forums.

Looks like everything is back to working order now. Until the next Windows/Kaspersky/whatever update screws up again the Asus software... 🙄😄

rexio
Level 8

I have lost many, many hours for reinstalling Windows and put all software on... lost my time 😞

But it is working now 🙂 Thanks for all support folks!

 

psikofunkster
Level 9

Apparently Kaspersky replaced the problem for another, today i got this windows 11 warning:

2023-06-08.png

What i got is you can't have two things like these activated at the same time so Kaspersky deactivated the Windows one as a "fix"...Is that the optimal scenario? i don't know. What i can tell now is Windows 11 displaying a warning permanently on the taskbar...

Did you try enabling again "memory integrity" option in the Windows Security? Give it a try and the warning should disappear without (fingers crossed) triggering any further problems with Asus software. Alternatively, just leave it disabled and under "Core isolation details" just tell Windows to "Ignore" that memory integrity is disabled and that too should cause the warning to disappear.

I can't enable but it enables itself after a few moments, however the warning remains.

2023-06-09.png2023-06-09 (1).png

What about leaving memory integrity enabled in Windows and disabling virtualization in Kaspersky then? If that does not work either, but everything seems to be working correctly, then just let Windows show the warning: I realize it is annoying to have any kind of warning show up, but this one does not seem to be a real problem or a "threat" to your PC, so it is seems safe to leave it alone.

SOLUTION FOUND------>AsusCertService
Well, after 12 hours of investigating this error code, and after creating multiple restore points, I've come to the conclusion that this problem is caused by a disabled service.
This service is usually enabled by default, but some scan/repair software tools like Advanced System Care disables this service through the manual optimization feature/process.
To fix this error, you must enable AsusCertService in the optimization panel in whatever repair/scan utility tool you use. If you don't have any repair utility, then do the following steps to enable this service:
1- Type services in the taskbar search box.
2- Left-click services one it appears.
3- Locate AsusCertService.
4- Righ-click it and choose properties from the menu.
5- Set the Startup type to Automatic and click on start then OK.
Not sure if you need to restart here or not. In my case, I didn't need to.

psikofunkster
Level 9

Thanks for your interest. 😄

I think my problem is related to this and all this kaspersky issue triggered it:

https://learn.microsoft.com/en-us/windows/release-health/status-windows-11-22H2#3048msgdesc

Only affects Windows 11 btw.

I kind of "solved" it, There was a brief moment when i click on the discard text i did it and now the warning is gone.

However the thing i could never check was this:

To discover if LSA was started in protected mode when Windows started, search for the following WinInit event in the System log under Windows Logs:

  • 12: LSASS.exe was started as a protected process with level: 4

Never found that line anywhere i hope the service is running.

Update:

NVM warning is back, however i consider this is now a Kaspersky issue so posting there instead of here.

cajudoido
Level 9