cancel
Showing results for 
Search instead for 
Did you mean: 

Error code 2: File Not Found - AsIO3.sys!!

Lmnsour
Level 8
Rog Strix Z690 D4 board.

I just updated from Windows 10 to 11 and its a fresh install. Can't run Armory Crate or install AsusAI suite due to no AsIO3.sys file installed. Armory crate installs but doesn't launch. AISuite won't install at all.


Troubleshooting:

-All devices in device manager are installed.

-I tried every step listed in my google searches with no help (most help articles are for Error Code 5).


Questions:

-How do I manually install the AsIO3 drivers?

-Is there something I may have disabled / need to enable in Bios?
18,524 Views
58 REPLIES 58

Bjervus
Level 7

Hi there!

I got exactly the same problem as you yesterday. How much I try to solve it impossible. Can start armory now, but it doesn't show anything, except TOOLS and NEWS. Can't even install the AI Suite 3, then I get the same fault code over and over again.

OpteMilko
Level 7

Hi. The same problem. Can't install Fan Expert to tune the funs. They are rocking like mad!

UPDATE: seems the problem is memmory integration feature in windows security. As soon as you turn it off , everything is fine.

psikofunkster
Level 9

Well i have bad and good news

the bad is the thing we already known it doesnt matter if you reinstall or uninstall armoury crate the problem persist

0 communication from asus

and because im not gonna wait forever… clean windows install courtesy of asus wee!

the good is that if you perform a full windows clean install and the you install armoury crate problem solved lol

ive heard armoury crate was bloated sofware but i gave it a chance since last january with my new mobo all good until yesterday…my pc was workkng just fine.

i gave avast 3 strikes before changing software im giving asus just one.

im not reinstaling this software again when i can install each driver separately and without bloatware.

Update:

i finished reinstalling Windows 11 without armoury crate and now i dont have:

the dts plugin

sonic studio 3

Aura sync so my rog strix card cant change colors

 

sigh…guess im gonna give it a second chance to armoury crate my z790 is still new for practical puposes…

Caglayan35
Level 8

Im having the same exact issue suddenly i started to get the error tried to uninstall and re install it  didn't worked im using Asus Tuf Gaming Z790 Plus Wifi d4 mobo  , if anyone find a solution pls let me know  its driving me mad .

Arlantir
Level 7
 

Hi everyone, this helped me for win 11

  • Go to Windows Security

  • Go to Device Security

  • Go to Core Isolation

  • Turn "Memory Integrity" off

  • Reboot

  • Run the Armoury Crate installer once more and see if the error persists.

Hi Everyone, I just tried this solution  and did not get the error after reboot

  • Go to Windows Security

  • Go to Device Security

  • Go to Core Isolation

  • Turn "Memory Integrity" off

  • Reboot

Thanks m8! That make my day. Work as good as before now.

 

bro, it is working!

ASUS idiots should hire you as a way better software specialist than they are.

Berserker79
Level 8

I'm on Win11 Pro and everything was working fine and then I started receiving the Error Code 2 for ASIO3.sys two days ago. Initially, Armoury Crate would open only after a substantial delay and I could still see all tabs, but only my AIO cooler was detected and no more trace of the mainboard and led strip. As of yesterday, I see only the Tools and News tabs and nothing else at all.

I did not install anything or receive any update, so I suspect either Asus or Microsoft silently pushed some update or change that screwed things up. Since I read that the problem could be the memory integration feature in Windows security, I'm beginning to think MS is the culprit (maybe they kind of blacklisted ASIO3.sys?). I'm going to give the suggestion of turning off "Memory Integrity" in Core Isolation, reboot and see whether that fixes the issue.

UPDATE: Fixed! Just follow the steps posted by Arlantir above, reboot and Armoury Crate returns to function properly, no need to re-install anything and especially no need to go through a whole re-install of the OS.

 

psikofunkster
Level 9

Im back

After a clean windows 11 install with armoury crate things were going good until i installed an application installer utility from Microsoft released exactly the same date this issue started now im back at the beggining with the same problem sigh…


BTW i dont think deactivating security core to fix this is a good idea…just saying