Showing results for 
Search instead for 
Did you mean: 

Can't install latest version of LiveDash for Maximus XI Formula

Level 9
Hi everyone

Since getting my Maximus XI Formula, my experiences so far with ASUS software have been a nightmare. At one stage previously I went through so much trouble with Aura that I ended up having to completely re-install windows. IMO that is not something one should have to do when dealing with basic driver software direct from the motherbaord manufacturer.

Today I made the stupid decision to try and update some of my drivers since there had been new releases since I last installed them quite a few months ago. Doing this was a reminder that I probably shouldn't bother in future.

The two pieces of driver software giving me trouble was ASUS AURA (as usual) and LiveDash. The previous versions I was on were AURA 1.07.35, and LiveDash 1.04.00. I started by downloading the latest versions which were AURA 1.07.66 and LiveDash 1.05.03. I then uninstalled the previous versions first, restarted and tried to install the new versions as administrator via ASUSsetup.exe. Both would open the install window, allow me to choose my installation location (default) and then they would start installing and just hang on 0%. When this occurs I can't open anything else, or even shut down or restart via windows. Sometimes it even freezes my whole system. Regardless all I can do when it occurs is forcibly shut the system off via the power button.

I tried using Revo Uninstaller to get rid of anything else relating to the previous versions and then installing them again, but after doing that the ASUSsetup.exe and Setup.exe won't even open the install wizard, it just hangs on a spinning loading circle. I should also mention my anti-virus was disabled this whole time...

I tried reverting to the previous versions of AURA and LiveDash, which installed fine, but when trying to launch them they are immediately blocked by Windows, I've read this is an issue with Windows 10 1903 and has something to do with the older versions of ASUS software having outdated certificates. I was able to get around this by downloading AURA version 1.07.60, which installed fine and works properly as far as I can tell, but with LiveDash there is no other option. There is only the release I was previously using, and the latest one which hangs when trying to install.

Is there any way to get the new version to install? I have no idea what's making it hang. My anti-virus is off, I'm running it as admin, both ASUSsetup.exe and Setup.exe do the same thing and Revo Uninstaller isn't helping. Until this is resolved I can't use my LiveDash as neither of the two software versions available for my motherboard work.