cancel
Showing results for 
Search instead for 
Did you mean: 

Built new system around ROG z90 Extreme Hero - Gamefirst VI locks things up

Melina
Level 10

Hi, I've successfully assembled a PC around the above-named motherboard and ROG 4080 OC Nvidia graphics card. All is running generally fine (other than the fact that I get intermittent lockups if I try to use AI Overclocking and XMP I/II/Tweaked, but I assume that may be a QVL issue with the Corsair Renegade 6000 RAM I am running in it, two sticks totaling 32gb; all tests out fine).

My software issue is this, and I'm sorry if this has already been reported here extensively: with the EA Games Launcher/Store app, which is required to run any EA Game, if I have Gamefirst VI on, whether set to Adaptive Intelligence or Gamefirst, it seems to have some sort of interaction (probably with EA's use of AntiCheat) that locks up the system and causes automatic exit of the game. If I exit Gamefirst VI and do a repair on the install of the game just tried, and then try again to run it.... everything works great!

I'm hoping for fixes on both fronts -- Gamefirst VI and Armoury Crate, for this board (using 14900K Intel CPU) -- so for now, I run games without AI Overclocking or XMP enabled (doesn't seem to make much difference in AC's reporting of CPU and RAM speeds, oddly enough, so okay!), and exit Gamefirst VI which I have set to autolaunch on startup before starting any EA game.

It's a lot to keep in mind especially after I've resurrected my system with this new build (an old Maximus Extreme V build blew up in my face, either from age, hacking or who knows what, I'll never know, but seems the CPU was burned and I decided it was time to go crazy and build My Last Computer instead of continuing to try to resurrect a system that would only issue Q Code 0 no matter how minimally I tried to start it up or flash the BIOS (1903)). So I hope there are fixes soon.

Thanks for listening!

116 Views
0 REPLIES 0