Showing results for 
Search instead for 
Did you mean: 

Aura Sync Not Working With Asus ROG STRIX RX 580 T8G

Level 7
Hello everyone,
* So I’m having trouble with getting Asus Aura Sync to work with my ASUS ROG STRIX RX 580 T8G graphics card. I recently had to reinstall Windows 10 on a new SSD (clean install) and now I’m unable to use Aura at all. I’ve tried numerous versions of Aura sync, including the version which was shipped on cd with the graphics card (which worked for months on my dead SSD) up to the current version. They would install cleanly and when I try to open them the older version would give a pop up saying “NO -aura” with no option but to close the window. *While opening the newest version of Aura caused an error basically saying the application has become unresponsive and must close. Each time I uninstalled the programs using Advanced Uninstaller to be thorough and even used AuraCleaner and continued to reboot when required and between installs.

* After trying all that I went and shut down and unplugged my PC to let the capacitors drain hoping for a reset to occur. And continued to remove the graphics card and let the pc boot to BIOS before shutting it down and reinstalling it and rebooting.*Now trying to install Aura gives me an error saying”Error: -1605 This action is only valid for products that are currently installed.” This happens for every and any version of Aura software I try.

What I Know:
>I know my graphics card is compatable with Aura Sync because my last SSD (also Windows 10) ran Aura fine for months. And the only new hardware is the SSD which is functioning beautifully.
>I’m sure it’s not the Aura software because of the inconsistency in results when starting this ordeal and how it wound up with similar results now.
>I know it’s not the graphics card because it runs like new, the LEDs are operational (uncontrollable due to the lack of Aura control). All managing I do of electronic parts I ensure a proper grounding connection to prevent ESD damage.
>Seems like Aura is unable to recognize my GPU.

* My OS is fully up to date, I think the firmware of the graphics card is up to date drivers are all up to date (directly from the firmware of my motherboard is up to date. I installed GPU Tweak2 and Radeon Control software and they function properly.

* Anyone with any ideas please let me know. Im incredibly lost and appreciate any attempt.

XFX Bravo Type-01
ASUS ROG Crosshair V Formula-Z
AMD FX-8350 Black Edition
G.SKILL Ripjaws Z Series 32GB (4x8GB)
ASUS ROG STRIX Radeon RX 580 T8G-Gaming
Corsair HX1200i 80+ Platinum
2x Samsung 860 Evo 500GB
WD Black 3TB
ASUS PCE-AC88 4x4 Wireless AC3100 PCIe Adapter