cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Rog Strix Go 2.4 Not Connects to PC, Not Initiate the Update

Douq4n
Level 7

Hello everyone, I bought this headset a month ago and I was using this headset without updated since I bought. Yesterday, I tried to update this from armory crate, but its failed about error that saying same thing, set headset to off and connect with cable etc. I did everytime but it keeps showing me that error. So I decided to download the update from website to manually update it. After few try (exe file opens cmd and after few minutes occurs error about 254, 21 etc.) I was able to see some numbers, codes. I tought its updating and waited like an hour. But it didnt complete. I keep computer awake whole night but when I woke up morning it was still continue. I closed the window and restarted pc.

Also B_Headset (HS) seem finishing the update but it occurs again.

Rog Strix Go 2.4 update is not iniating from armory crate, keep says that I must headset off, connect type-c.

When i use update.exe file sometimes it fails as i said. Now its started I added the picture here but as i said its like forever.

So here is my problem now my headset is not working. I set on and clicking the button but blue light not shows up. I tried cable its still not working. Once I saw blue light blinked but i lost it too. Now my pc cant detect device, no rog strix name under sound section. Cant see on device manager. 

 

I would really appreciate it if someone could help me solve this problem. I removed the device from the device manager, uninstalled the file with the same name from the control panel and connected the device to pc. Uninstalled the all asus softwares and reinstalled. Restarted pc. This doesn't working either.

 


PC ( Windows 10 64 bit, Motherboard Asus H610M-K.)

160 Views
0 REPLIES 0