cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Livedash not finding RYUO

skittlemonzter1
Level 7
I have just changed almost everything in my PC, including putting a Maximus X Hero with Wifi in, along with the RYUO 240mm. Well after I finally got the software livedash installed, I now cannot load the program. When it tries to boot up, after about a minute is pops up saying "Asus device no found !!" Am I doing something wrong or is the software having issues? I am not sure what is going on here. Thank you for any help!


EDIT: Also, Aura Sync is not picking up the RYUO as well, but AI Suite is.
273 Views
14 REPLIES 14

Cutsick
Level 7
Same issue. The download page linked and any search results point you to the AI Suite III download. Has anyone been able to use the Ryujin display for anything more than the default ROG logo?

mdzcpa
Level 12
I seem to be running ok here. Everything is functional.

Installed in this order:

Flash AIO with newest Firmware 1.00.05 (build 1012)
Install (or Reinstall) AI Suite III 3.00.28
Live Dash 1.04.01
Lighting Control 1.07.22 (optional)


All files can be found on Ryujin download support page except Lighting Control.
Lighting Control is optional. Live Dash can also run the RGB. I use LC to sync with my mobo.

mdzcpa wrote:
I seem to be running ok here. Everything is functional.

Installed in this order:

Flash AIO with newest Firmware 1.00.05 (build 1012)
Install (or Reinstall) AI Suite III 3.00.28
Live Dash 1.04.01
Lighting Control 1.07.22 (optional)


All files can be found on Ryujin download support page except Lighting Control.
Lighting Control is optional. Live Dash can also run the RGB. I use LC to sync with my mobo.


Would you be so kind as to link to this support page? The only software visible to me to download from any of the coolers driver pages is the AI Suite III 3.00.28 software. I cant find Livedash.

**Update** Ok found it - You need to click "Expand All" from the driver download page to see the other utilities.

Just tried the latest driver, and still not detecting. Looking throughout the forums of various places it seems this whole product release has been nothing but a complete mess, and having "reinstall Windows" as my only suggestion from Asus is beyond unacceptable. I hope one day they'll fix this screw up of a product.

BeatUp
Level 7
Wanted to update my situation.
I managed to get the newer revision Live Dash 1.04.01 and now it is actually working.
I did not do anything special really. Just downloaded it and installed. Just works now.

Next to tackle the Halo software xD