cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Driver Download page not loading after putting in OS??

xPepi
Level 7
Thoughts? Nothing happens when I put in my OS

67610
781 Views
12 REPLIES 12

SilentShadow85
Level 7
I'm having the same problem as you with both my laptop and my PC, also it is happening using both Chrome and Edge browser.

Anyway have any idea what's going on?

SilentShadow85
Level 7
xPepi wrote:
Thoughts? Nothing happens when I put in my OS

67610


I've found the solution, in my case anyway!

On my ASUS router (RT-AC66U using Asuswrt-Merlin firmware) I have installed "AB-Solution", its an ad blocker (and a very good one, highly recommended!) even though the ad blocker did not block the entire asus domain it did block a domain that has something to do with analytics by yahoo, Asus probably added this analyses not too long ago, i've just paused the adblock refreshed the page choose my OS and the list showed up without a problem, afterwards using Google Chrome browser I have opened the developers tools to find out which domain is loading on the page and I have found this one; "sp.analytics.yahoo.com" after adding it to the whitelist on my ad blocker I have unpaused my ad blocker and tested the page again and this time it loads without any problem.

Good luck, hope this info helped you!

JustinThyme
Level 13
Try a different browser or flush dns and clear cookies



“Two things are infinite: the universe and human stupidity, I'm not sure about the former” ~ Albert Einstein

JustinThyme wrote:
Try a different browser or flush dns and clear cookies


Flushed DNS, cleared all browser/cookies history, tried Microsoft Edge instead...didn't work.

Justin, are you able to get something to load when you try to access drivers after putting in your OS specs?

The only thing I can think of is that HOST files is blocking it...but why...

Downloads worked for me before...but it has been a few months since I went in to get something.

Oddly enough, I can access and download the BIOS updates but no drivers/utilities.

xPepi
Level 7
Oddly enough, I can access and download the BIOS updates but no drivers/utilities.

Clouseau
Level 7
The answer is as stated by SilentShadow85 or just allow cookies. I have refused to whitelist anything so the other option is to change the country code in the web address string. ASUS is not consistent is its application of that tablet friendly interface; stupid for downloading for a mainboard for a desktop PC. One size fits all does not work and they are not even consistent in that aspect of follow through. Just need to find a country code that still uses the "old" format.

toronto699
Level 13
try this download page works for me enter Model Name Search
http://support.asus.com.cn/download/options.aspx?SLanguage=en

toronto699 wrote:
try this download page works for me enter Model Name Search
http://support.asus.com.cn/download/options.aspx?SLanguage=en


Thank you!

toronto699 wrote:
try this download page works for me enter Model Name Search
http://support.asus.com.cn/download/options.aspx?SLanguage=en


That did the trick over here.

Thanks!