Showing results for 
Search instead for 
Did you mean: 

Asus Aura acting strange with G.Skill Trident Z RGB memories

Level 7
hi guys, i have a weird problem wince a week ago, and even bios update did not help, from the past week my mainboard started to do some crazy stuff, first two times in a row when i restarted the PC it gave me a message telling me it's updating RGB LED firmware, then now most of the times when i install or run asus aura, some of my memory modules will not sync with others, sometimes 2, sometimes 4, sometimes more, but most of the times it's two of them, one from each side.

like there is everything synced in there, except some of ram's, i have rampage VI extreme, 64GB trident z RGB 3200MHZ, intel i7 7820x, GTX 1080 strix SLI 2x.

i checked in aura they are added and they should be synced, i tried new OS, problem persists, restarting the lighting service sometimes work, only sometimes, i tried clean install of almost everything, unsync and sync memories also does not work.

so here is the question, how do i fix this? anyone had this problem before? is it possible to manually update RGB firmware again to see if the problem is solved? i already have installed 1503 Bios version.