Showing results for 
Search instead for 
Did you mean: 

Armoury software won't open [Resolved]

Level 7
Okay I'm not really sure what's going on here but the rog armoury software wont open. I keep getting a prompt that tells me to turn off aura software.
I tried everything to get this to work , it worked a couple of times but not now. It stinks because I bought the strix flare with great exspectations and now I have a 175.00 dollar keyboard that I cant even get to work right. Can some one please advise.

Level 7
Thanks for all those who replied.

I finally figured this out

Community Admin
Community Admin
Our notification should be clearer, sorry about that. Peripherals need to be unsynced (device list on the top each with a sync/unsync button) in Aura software before opening Armoury, do not just close the Aura software.
FPS, Racing & VR Gamer / Tech Enthusiast / ROG Admin

How can I resolve this issue?
I have AURA installed and ROG Armoury. I have AURA in the off setting. But when trying to open Armoury I get the same error.