cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate Still Broken. Can't Access Ryujin or Fan Xpert

Hoverboy
Level 8
There was an update to Armoury Crate on 4.25 that broke access to all devices in Armoury Crate, and would throw a script error every time the PC woke from sleep. Even a full uninstall/reinstall didn't resolve the issue. After looking around online it was apparent that this was fairly widespread, so I waited for an update. The software for the motherboard, GPU, Ryujin, and FanXpert all updated to 2.1.3.0 this morning, which resolved the script errors that were popping up, but I am *still* unable to access Device -> ROG Ryujin II or Device -> FanXpert. Clicking either of these results in a quick flash and then black space in the UI, and eventually the following error pops:

We are sorry there is an error on the device page. The application is going to reload the device page now (2006)

So I've lost the ability to edit/update the display on the Ryujin (it's just a repeating default gif for weeks now) and I can't access the fans at all. We're entering the third week of this software being broken. Are there any third-party options for the Ryujin II screen or FanXpert? I'm ready to dump Armoury Crate at this point.

Current version of Armoury Crate: 5.1.5.0
5,064 Views
11 REPLIES 11

Nate152
Moderator
Hi Hoverboy,

Welcome to the ROG forum.

Unfortunately, the device page error will require a windows reinstall.

Nate152 wrote:
Unfortunately, the device page error will require a windows reinstall.


Thanks for the reply, but reinstalling an entire operating system is a massive ask of people depending on how much they use their PC. Like, multiple days of setting everything back up massive. Things were working fine, Asus rolled out an update on April 25th that broke things, and now their "fix" is for the end users to reinstall Windows?

Is there a 3rd party option to get the display on the Ryujin II to show what I want, because making me reinstall my operating system really, really makes me want to uninstall Armoury Crate.

Hoverboy wrote:
... reinstalling an entire operating system is a massive ask of people depending on how much they use their PC. Like, multiple days of setting everything back up massive.

I agree completely. I'm sure there are people who have simple installations, just Windows at mostly default settings and a couple apps or a few games. But for people who have lots of apps, and customize their settings, it is a massive days-long task to reinstall the OS and apps.

Hoverboy wrote:

Is there a 3rd party option to get the display on the Ryujin II to show what I want, because making me reinstall my operating system really, really makes me want to uninstall Armoury Crate.

I have not seen any 3rd party tool to control either the display or the pump and embedded fan of the Ryujin-II. AIDA64 can display some stats/temps on the screen, but I do not know if it can do that without AC installed. Personally, I will never again buy a pump/radiator that cannot be plugged into standard fan/AIO headers and controlled entirely from the BIOS or 3rd party tools.

I did run my Ryujin-II for a while without AC, letting the pump and internal fan use whatever their firmware defaults are and connecting the radiator fans to the MB for bios control. That mostly worked but wasn't the best in terms of fan/pump response to high load, and of course the display just shows the default animation. AC is really the only option (at least right now) that provides full control of the Ryujin-II.

My suggestion would be another complete uninstall using the ASUS AC uninstall tool. Then reboot and run Windows Disk Cleanup to delete all temporary files. Then try the AC installation again. There have been multiple AC component updates in the last few weeks (several in just the last couple days), so hopefully you'll have a better result than you have now. Also be aware that the installation may fail multiple times, usually complaining about internet, so you may have to run it multiple times before it succeeds.
-----------------------------------------------------------------------------------------------------------------------------------------------------
Z690-E, i9-12900k, 2x16 DDR5, 980pro nvme x3, Ryujin-II 360, Strix Animate-II, Evga 3090 ftw3

RogScott wrote:
My suggestion would be another complete uninstall using the ASUS AC uninstall tool.


Thanks for the reply & suggestion. Do you happen to have an official link to their uninstall tool? As of last week it was MIA on Asus websites, resulting in 404 Unauthorized Access errors, and the only options to download it were from people posting versions that they had up to OneDrive/Google Drive on one of the Asus sub-reddits.

Nate152 wrote:
Hi Hoverboy,

Welcome to the ROG forum.

Unfortunately, the device page error will require a windows reinstall.


Hi,
Could you please elaborate. Is this a serious reply!? I notice you have Moderator tag, is this really not a joke post? My first post here.

As others mentioned uninstalling an entire OS because of Armory Crate being broken only to have to continue to deal with broken Armoury Crate. It's not like it's a one off broken version of Armory Crate. or the first post on here about problems with Armory Crate.

I've been buying Asus Mobo and other asus hardware for 20 years. If this is what meets the ASUS standards of being good enough for paid customers. I'll look elsewhere on next build.
Shame. 😞

Nate152
Moderator
Sure,

You get the Armoury Crate uninstall tool from the ASUS Support Center.

Select your operating system then click Show all, it's the third download.

https://www.asus.com/supportonly/Armoury%20Crate/HelpDesk_Download/

jzer0912
Level 9
Getting this error since this morning, all components in Armoury Crate are up-to-date. Fan speed stays at lowest setting, not increasing along with temperature. This is a danger to the hardware and cannot use my machine until fixed. This is definitely coming from Amoury crate:

bundle-3497a882c9eb630b38d3.js

(self.webpackChunkfrontend_devices=self.webpackChunkfrontend_devices||[]).push([[289],{38289:function(e,t,r){"use strict";r.r(t);const i=Object.freeze({NORMAL:"0",PLC:"1"});t.default={device:"ROG FAN CARD 3",guid:"19a626ed-783a-4d0e-8e7b-5fa069ad348b",productName:"fancard",deviceType:"15",theme:"rog",profileCount:1,deviceProps:{},functionList:[{id:"FanControl",text:"Fan Control",langRef:"row_517"},{id:"Lighting",text:"Lighting",langRef:"row_4"},{id:"FanInfo",text:"Fan Info",langRef:"row_563"},{id:"FirmwareUpdate",text:"Firmware Update",langRef:"row_77"}],fanControl:{hasApplyTo:!0,hasDefaultBtn:!1,hasResetBtn:!1,hasFanTuning:!0,hasFanSpinUp:!0,hasMarkIcon:!1,hasCheckMode:!1,canDefineTempSource:!0,hasDoNotShow:!0,rpmTooltip:"row_555",fanProfileDefaultBtn:!1,isSetGetFanInfoEvent:!0,fanInfoEventTimer:"3",settingList:[{id:"0",name:"Silent",langRef:"row_519",iconType:"fanProfileSilent"},{id:"1",name:"Standard",langRef:"row_520",iconType:"fanProfileStandard"},{id:"2",name:"Turbo",langRef:"row_521",iconType:"fanProfileTurbo"},{id:"3",name:"FullSpeed",langRef:"row_522",iconType:"fanProfileFullSpeed"}],mappingTable:{SILVERSTONE:{text:"SILVERSTONE",className:"silverstoneLogo"},BITFENIX:{text:"BITFENIX",className:"bitfenixLogo"},"Asus ROG":{text:"Asus ROG",className:"rogLogo"},"AP140i HYDRANODE":{text:"Air Penetrator 140i HYDRANODE"},"Spectre HYDRANODE":{text:"Spectre™ AI Addressable RGB Fan"},CF1225U12D:{text:"CF1225U12D"}},switchList:[{id:"isAsusHydranode",title:"ASUS HYDRANODE",btnText:"row_78"}],temperatureSource:[{id:"0",name:"CPU"},{id:"1",name:"TS1"},{id:"2",name:"TS2"},{id:"3",name:"CPU (package)"}],fanType:i,mapPercentage2Rpm:(e,t)=>{if(!t)return"0";if(e<0||e>100)return"0";t.sort(((e,t)=>Number(e.percentage)-Number(t.percentage)));for(let r=0;r.percentage))return String(t.rpm);if(e>Number(t.percentage)&&e.rpm))/(Number(t[r+1].percentage)-Number(t.percentage));return String(Math.floor(Number(t.rpm)+i*(e-Number(t.percentage))))}}}},lighting:{hasAuraSync:!1,hasMutiSource:!0,effectList:[{id:"0",text:"row_210",className:"statics",items:[{id:"colorLevel",text:"row_45",options:[{id:"Single"}]}]},{id:"1",text:"row_211",className:"breathing",items:[{id:"colorLevel",text:"row_45",options:[{id:"Single"}]},{id:"speed",text:"row_60",options:[{id:"2",text:"row_61"},{id:"1",text:"row_62"},{id:"0",text:"row_63"}]}]},{id:"2",text:"row_248",className:"strobing",items:[{id:"colorLevel",text:"row_45",options:[{id:"Single"}]},{id:"speed",text:"row_60",options:[{id:"2",text:"row_61"},{id:"1",text:"row_62"},{id:"0",text:"row_63"}]}]},{id:"3",text:"row_212",className:"colorcycle",items:[{id:"speed",text:"row_60",options:[{id:"2",text:"row_61"},{id:"1",text:"row_62"},{id:"0",text:"row_63"}]}]},{id:"4",text:"row_213",className:"rainbow",items:[{id:"speed",text:"row_60",options:[{id:"2",text:"row_61"},{id:"1",text:"row_62"},{id:"0",text:"row_63"}]}]},{id:"5",text:"row_218",className:"starrynight",items:[{id:"speed",text:"row_60",options:[{id:"2",text:"row_61"},{id:"1",text:"row_62"},{id:"0",text:"row_63"}]}]}]},fanInfo:{timer:1800}}}}]);

93038

cekeu
Level 12
If you have a registry cleaner running in the background, that's what breaks the software.

I tried to reinstall several times, the device's page was always timing out.
Uninstalled everything with the Armory Crate removal app, rebooted and etc, nothing would solve the problem.

What fixed for me was fixing the Windows time and the hardware clock by doing like this:

It can be done by a simple registry fix: Open regedit and add a DWORD value with hexadecimal value 1 to the registry:

93082

Should Windows ask to update the clock due to DST changes, let it. It will leave the clock in UTC as expected, only correcting the displayed time.

Then, reboot and test if the device's page will open, here it fixed and never happened again.