cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury crate fails to display devices and update

zorel
Level 7
Hello.

I removed crate months ago, and now i want to install it again to use with Corsair iCUE.

Installation goes fine, but on reboot, Crate, shows on left only some of my device (strix flare and z370-i but not my strix 1080Ti). When I click on one device, wait spinner, and finally an error saying it will reload the page which fails same way.

In the update section, i see some update for flare & z370-i, I click update all, and it still displays the update. Even after reboot, same thing.

Tried to uninstall/reinstall, clean the directories programdata/asus and program x86/asus, auracleaner, still fails.

What am I missing, appart the poor quality of the software, to make a working install ?
986 Views
2 REPLIES 2

Hawaiitoast
Level 7
zorel wrote:
Hello.

I removed crate months ago, and now i want to install it again to use with Corsair iCUE.

Installation goes fine, but on reboot, Crate, shows on left only some of my device (strix flare and z370-i but not my strix 1080Ti). When I click on one device, wait spinner, and finally an error saying it will reload the page which fails same way.

In the update section, i see some update for flare & z370-i, I click update all, and it still displays the update. Even after reboot, same thing.

Tried to uninstall/reinstall, clean the directories programdata/asus and program x86/asus, auracleaner, still fails.

What am I missing, appart the poor quality of the software, to make a working install ?


I got Exactly the same problem here...

Hawaiitoast wrote:
I got Exactly the same problem here...


Me to 👌 the change is coming....
Coming with msi or gigabyte I'm not willing to wait much longer all the money Asus make they can't pay a good enough team to find and fix this problem is a joke