cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate damaged my whole system

Era3tone
Level 7
So I bought a asus rog strix g few weeks back and now on after 2 weeks. It started giving me problems and I mean a lot of them.
So when I received the device, it worked great and everything was good for a week then suddenly the armoury crate stopped saving profiles or lost it's functionality. The aura sync was gone and the rgb was stuck on color cycle. Then some minor bugs came as well and I reset ed the laptop to maybe solve this issue.

After the reset and first boot the device seemed to work fine again but after a restart to install updates, the problems came so after some googling I choose to reset again and stop the asus live service under services.msc option. This option seemed to work, a had to suffer with some bad rgb but the laptop was working great again. But yesterday after some update or something the rog key to open the armoury crate does not work and also the fan change profile to set to other modes stopped working at all. I had to manually open armoury crate and there was no aura sync menu and the rgb was stuckeat color cycle now.

Then came another big blow and this was the most annoying, the laptop started to stutter a lot and was slow even in simple file transfer. I looked in the background processes and there was a process called armoury crate user session which was opening again and closing which maybe causing stutters but the laptop is seriously slow. I had a ssd installed and to transfer 3gb file it took me 30 min. I played csgo earlier and it ran at 140+ fps at high setting but after this problem, csgo ran at 50 fps with too many 1% low that it was not playable anymore. I did also installed drivers again manually but it did not solve the problem, I don't think it's a hardware problem as everything works after a reset but after a restart back to square one. If anyone also encountered this problem please do help me. I called for the asus service and hope they fix it fast as I have to leave for college in 2 weeks now.

This being my first Asus laptop and being greeted with this changed my mindset about the one time great asus. Still if anyone can please help me !
86,266 Views
28 REPLIES 28

AngryAce
Level 7
From what I can tell, very little help is offered by Asus on this forum. I have 3 Asus motherboards and Armoury Crate doesn't work on any of them anymore. 2 of them have never worked correctly and the 3rd is my newest AMD build. X570 CH8 and Strix 5700XT worked ok until the lastest round of AC updates. AC doesn't detect anything and when it does, can't change the lighting or patterns. Just stuck on random colors or rainbow. Just like the other 2 systems I have. Disappointing to say the least.

Performance wise, the systems run great so if your having issues, I suggest tech support.

AngryAce wrote:
From what I can tell, very little help is offered by Asus on this forum. I have 3 Asus motherboards and Armoury Crate doesn't work on any of them anymore. 2 of them have never worked correctly and the 3rd is my newest AMD build. X570 CH8 and Strix 5700XT worked ok until the lastest round of AC updates. AC doesn't detect anything and when it does, can't change the lighting or patterns. Just stuck on random colors or rainbow. Just like the other 2 systems I have. Disappointing to say the least.

Performance wise, the systems run great so if your having issues, I suggest tech support.


FWIW, reading this 3 years later and the problems with Asus offering help are unchanged. I spent thirty minutes on the phone with them again this morning and see no help forthcoming in the foreseeable future. What makes it worse is that even after you remove armoury crate, I still get popups from Malwarebytes about the program trying to send data out on my computer. It's frustrating at best. I may have to reinstall the OS completely and start from scratch, assuming I can stop the stuff from loading (it's in the BIOS).

Chrizzy
Level 7
Asus gives a ****... 😕

edrickjk
Level 7
The only way i found to deal with armoury crate is with a fresh window install, to stay away from ai suite ,aura and and any other asus software,they seems to conflict with each other. If any of these was previously installed, armoury wont work and prevent the other one to work properly.

Like other said its only software related ,your hardware is ok, take little to no time to do a fresh install these day .

edrickjk wrote:
The only way i found to deal with armoury crate is with a fresh window install, to stay away from ai suite ,aura and and any other asus software,they seems to conflict with each other. If any of these was previously installed, armoury wont work and prevent the other one to work properly.

Like other said its only software related ,your hardware is ok, take little to no time to do a fresh install these day .


Nothing truer ever said about Asus software. My "4.5 hour" under Wi-Fi and YouTube use conditions laptop gives me barely an hour and the reason is because Armoury Crate is a crock of s***. It doesn't manage anything properly.

MrAgapiGC
Level 13
explain DAMAGE your whole system. If there is a issue by DAMAGE please prepare RMA Now FPS has nothing to do with app. nada.

if the app damage you laptop. prepare the RMA process.
Learn, Play Enjoy! We help and collaborate, NOT complain!

BigJohnny
Level 13
Cant speak for crate but AI suite bricked a board for me. Had saved profiles and had been OCing and simply set it to the saved default. Locked slap up and never posted again from either BIOS. Ive learned to just use the BIOS for these settings and seek out alternative software solutions as the guys in the dungeon doing the software dont get enough sleep and their espresso machine is broken.

Super_Gnome
Level 11
Yup, it's like Big Johnny here says. Use the Bios settings. I've got a near ten year old rig I built and it doesn't run any Asus software since switching it over to Windows 10. But it runs like a charm now with no garbage you know what software. Fortunately there is no RGB lighting though. As far as I could tell when poking around my new rig's Bios there is no way to control the RGB or LEDs from there.

I'll tell you what though, I've got the blue screen of death twice in the last couple weeks, and the problems started just around the time Armoury Crate lost control of the lighting, LED and updating. Also, your Armoury Crate problems sound a lot like mine.

KILLER_K
Level 10
RGB control from the bios would be great. But as bad as the software is I doubt that would be a smart thing to try at this point though. It is what it is. I shall wait and see what happens.