cancel
Showing results for 
Search instead for 
Did you mean: 

AiCharger.sys / Incompatible driver / Memory Integrity Windows 11

pacificstorm
Level 7
Hi all,

I tried to enable Memory Integrity. Unfortunately I can't because AICharger.sys is classified as an incompatible driver.
So I uninstalled AI Suite 3 where AICharger is a part of (according ASUS Support). AiCharger.sys still remains in C:\Windows\SysWOW64\drivers.
Now I followed a couple of suggestions from several forums:

  • Installing AICharger and uninstalling with Revo
  • Change Registry
  • Delete AICharger.sys manually
  • and so on

Nothing helped.
My last step was to contact ASUS Support. I gave them all the information as listed above. Here are their answers:

1st Answer ASUS Support:
Ai Charger+ is part of AiSuite 3, so if the app continues to be incompatible with that Windows 11 feature, AiSuite 3 will have top be uninstalled completely.


My Answer:
As I said, AISuite 3 is completely uninstalled. I used Revo Uninstaller.
But AiCharger.sys still exists in C:\Windows\SysWOW64\drivers. Deleting it causes a deactivation of all USB ports.


2nd Answer ASUS Support:
Please try to delete that driver, restart the OS and reinstall the Chipset driver. If you still have the same issue, it could be a compatibility error with the OS. In this case you will have to wait for a new OS update or try to speak with Microsoft support for assistance.


My Answer:
And that is the problem. How to uninstall the driver when the app is already uninstalled?
I can’ t delete it manually as there are Registry entries which are pointing to the driver.


3rd Answer ASUS Support:
We do not have information about the OS functions and features. If that feature of Windows 11 is not working we kindly recommend contacting Microsoft Support for assistance. We can only recommend a fresh reinstall of the OS at this point.
We hope that the given information will be useful and we wish you a great day.


So, they tell me to contact Microsoft, to ask them how to get rid of ASUS Software.

Maybe you guys have an idea to solve this issue.

Cheers
9,159 Views
11 REPLIES 11

katlani
Level 9
hey,

There are some utility cleaning tools from ASUS such as for AI Suite III, Aura and GPU Tweak II, though some of which are hard to find these days.

Have you tried the AI Suite III cleaner on your end?
Additionally, have you tried removing the registry keys via some 3rd party software like CCleaner?

Sharing the tools with you via some file-share service:

https://easyupload.io/m/9iusxp

Good luck.

Hi,

thanks for sharing the apps. Will test them tomorrow.

CCleaner would be my last choice.

pacificstorm wrote:
Hi,

thanks for sharing the apps. Will test them tomorrow.

CCleaner would be my last choice.


Any luck fixing this? I have the same issue.

Same Problem. Used also the UninstallAI3Tool to remove the crappy software. Didn't help.
If you someone have solution, please post.

EDIT: OK, for me it was the AsIO.sys. I deleted the service which runs this driver. After that, my error message was gone. I was able to activate memory isolation.

Hi Folks and ASUS ROG Team,

See also this thread: https://rog.asus.com/forum/showthread.php?124969-Asus-Ai-Charger-is-not-working-on-windows-11

Why should Asus update there drivers to Win 11 while anyone else does?!

Remembers me of CREATIVE LABS Drivers back in the days.

Mark

I used autoruns64.exe to delete the autorun for both:

  • aicharger.sys
  • asio.sys

This allowed me to turn on memory integrity, and not see any error messages when rebooting.

So far I haven't noticed any problems or missing functionality ...

Ended up using Autoruns64 and disabled AiCharger.sys but after that all USB ports were deactivated. Now I'm unable to do anything without mouse/keyboard; any suggestions would be really appreciated (felling stupid after that). And the worst is that I'm also unable to access it using Remote Desktop, which would save me from that.

Thanks a lot. This allowed me to turn on memory integrity finally, too! 🚀

katlani
Level 9
While I dont think CCleaner will actually clean an active registry key, rather orphaned ones, it won't really resolve any issue, just cleanup residues.
You might need to manually look for the registry keys and delete them yourself, as long as it is possible (in case the AICleaner and CCleaner do not solve it).

The worst case scenario would be a clean installation of the OS but sometimes its the safest way.