Showing results for 
Search instead for 
Did you mean: 

AI Suite III - USB Charger + Device not found

Level 7
I have an ASUS Sabertooth Z97 Mark 1 motherboard.
When I first set up the computer, I remember that the USB Charger + feature of AI Suite III detected my iPhone without issue.
Now, 1.5 months after setting up the computer, I just receive a Device not found message. I can confirm that the cord is plugged into the white-outlined USB port (labeled USB flashback). I have tried uninstalling, cleaning, and reinstalling AI Suite, I have tried rolling back all my USB drivers, and neither has worked so far.

I have another USB-related issue involving this motherboard and the UEFI BIOS; if I press del to enter bios on startup, and have my razer mamba 2012 plugged in, the bios freezes. If I unplug the mamba, I can use my keyboard to navigate the bios. This is an ongoing issue: ASUS wants me to RMA the issue away, but I'm not convinced that will actually solve anything. I'm talking with razer as well to see if the issue is (as I believe) software-related. I only mention this issue because it's also USB-related, and therefore might be connected to my USB Charger+ issue.

Any ideas?

Level 14
You should be able to uninstall the Charger Plus program through Programs and features, Then download the latest approved from Asus Support Downloads. I'm not sure of how your MB works but with our notebooks Charger Plus is a separate software. Also in my g75 the BIOS had a charger plus feature that will allow charging through q USB port with the notebook turn off. I don't have the window charger plus software install on either my G75 or my Z97 board I just don't need it for anything and with the G75 there were issues with it.
G752VY-DH72 Win 10 Pro
512 GB M.2 Samsung 960 Pro
1 TB Samsung 850 pro 2.5 format
980m GTX 4 GB
32GB DDR 4 Standard RAM

Z97 PRO WiFi I7 4790K
Windows 10 Pro
Z97 -A
Windows 10 Pro